summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-16 06:21:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-16 06:21:52 +0000
commit503cd7cb89510a35650be66f9008ec0f32bdcb28 (patch)
tree3e22a113fb826bd68316a3cc6b8079874bc02e91 /media-gfx/feh
parentold (diff)
downloadgentoo-2-503cd7cb89510a35650be66f9008ec0f32bdcb28.tar.gz
gentoo-2-503cd7cb89510a35650be66f9008ec0f32bdcb28.tar.bz2
gentoo-2-503cd7cb89510a35650be66f9008ec0f32bdcb28.zip
Make xinerama support optional #139594 by Viktor Griph.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'media-gfx/feh')
-rw-r--r--media-gfx/feh/ChangeLog7
-rw-r--r--media-gfx/feh/feh-1.3.4.ebuild32
-rw-r--r--media-gfx/feh/files/digest-feh-1.3.42
-rw-r--r--media-gfx/feh/files/feh-1.3.4-headers.patch18
-rw-r--r--media-gfx/feh/files/feh-1.3.4-xinerama.patch43
5 files changed, 93 insertions, 9 deletions
diff --git a/media-gfx/feh/ChangeLog b/media-gfx/feh/ChangeLog
index 84a89eaf018b..6c82f0c93ec3 100644
--- a/media-gfx/feh/ChangeLog
+++ b/media-gfx/feh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/feh
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.27 2006/01/20 00:50:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.28 2006/07/16 06:21:52 vapier Exp $
+
+ 16 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/feh-1.3.4-headers.patch, +files/feh-1.3.4-xinerama.patch,
+ feh-1.3.4.ebuild:
+ Make xinerama support optional #139594 by Viktor Griph.
20 Jan 2006; Mike Frysinger <vapier@gentoo.org> feh-1.3.4.ebuild:
Add modular X deps by Marcelo Goes #115988.
diff --git a/media-gfx/feh/feh-1.3.4.ebuild b/media-gfx/feh/feh-1.3.4.ebuild
index a7a86e5a6456..1bc9f0365afe 100644
--- a/media-gfx/feh/feh-1.3.4.ebuild
+++ b/media-gfx/feh/feh-1.3.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-1.3.4.ebuild,v 1.7 2006/01/20 00:50:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-1.3.4.ebuild,v 1.8 2006/07/16 06:21:52 vapier Exp $
+
+inherit eutils autotools
DESCRIPTION="A fast, lightweight imageviewer using imlib2"
HOMEPAGE="http://www.linuxbrit.co.uk/feh"
@@ -9,22 +11,36 @@ SRC_URI="http://www.linuxbrit.co.uk/downloads/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE=""
+IUSE="xinerama"
-DEPEND=">=media-libs/giblib-1.2.4
+RDEPEND=">=media-libs/giblib-1.2.4
>=media-libs/imlib2-1.0.0
>=media-libs/jpeg-6b-r4
media-libs/libpng
- || (
- ( x11-libs/libX11 x11-libs/libXext x11-libs/libXinerama
- x11-libs/libXt x11-proto/xproto x11-proto/xineramaproto )
- ( virtual/x11 )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXt
+ )
+ virtual/x11
)"
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xproto x11-proto/xineramaproto ) virtual/x11 )"
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e "/^docsdir =/s:doc/feh:share/doc/${PF}:" Makefile.in || die
+ rm -f configure.ac
+ epatch "${FILESDIR}"/${P}-xinerama.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ sed -i -e "/^docsdir =/s:doc/feh:share/doc/${PF}:" Makefile.am || die
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable xinerama) || die
+ emake || die
}
src_install() {
diff --git a/media-gfx/feh/files/digest-feh-1.3.4 b/media-gfx/feh/files/digest-feh-1.3.4
index 268af30ff3b8..964a45b78439 100644
--- a/media-gfx/feh/files/digest-feh-1.3.4
+++ b/media-gfx/feh/files/digest-feh-1.3.4
@@ -1 +1,3 @@
MD5 3d35ba3d2f0693b019800787f1103891 feh-1.3.4.tar.gz 409530
+RMD160 7e27d31cf974b30fc321d4dbef2fd46fbd21d34c feh-1.3.4.tar.gz 409530
+SHA256 81b9f2bbc15ffda4640958701753447b95cd2cbf11bc8e85dd00fdd2a2f83124 feh-1.3.4.tar.gz 409530
diff --git a/media-gfx/feh/files/feh-1.3.4-headers.patch b/media-gfx/feh/files/feh-1.3.4-headers.patch
new file mode 100644
index 000000000000..16070f770b04
--- /dev/null
+++ b/media-gfx/feh/files/feh-1.3.4-headers.patch
@@ -0,0 +1,18 @@
+--- src/md5.c
++++ src/md5.c
+@@ -39,6 +39,7 @@
+ */
+
+ #include "md5.h"
++#include <string.h>
+
+ #ifdef TEST
+ /*
+@@ -46,7 +47,6 @@
+ * The test program should print out the same values as given in section
+ * A.5 of RFC 1321, reproduced below.
+ */
+-#include <string.h>
+ main()
+ {
+ static const char *const test[7] = {
diff --git a/media-gfx/feh/files/feh-1.3.4-xinerama.patch b/media-gfx/feh/files/feh-1.3.4-xinerama.patch
new file mode 100644
index 000000000000..af435d02cf14
--- /dev/null
+++ b/media-gfx/feh/files/feh-1.3.4-xinerama.patch
@@ -0,0 +1,43 @@
+--- feh-1.3.4/configure.in
++++ feh-1.3.4/configure.in
+@@ -41,11 +41,25 @@
+ AC_SUBST(GIBLIB_CFLAGS)
+
+ dnl Check for Xinerama
+-LIBS="-L/usr/X11R6/lib $LIBS -lm -ljpeg"
+-AC_CHECK_LIB(Xext,XMissingExtension)
+-AC_CHECK_LIB(Xinerama,XineramaQueryScreens)
+-AC_SUBST(HAVE_XINERAMA)
+-AC_SUBST(XINERAMA_LIBS)
++AC_ARG_ENABLE(xinerama,
++ AC_HELP_STRING([--disable-xinerama],[disable Xinerama multi screen support]),
++ [
++ if test x"$enableval" = xyes; then
++ with_xinerama="yes"
++ else
++ with_xinerama="no"
++ fi
++ ],
++ [with_xinerama="detect"]
++)
++if test x"$with_xinerama" != xno; then
++ AC_CHECK_LIB(Xext,XMissingExtension,[
++ AC_CHECK_LIB(Xinerama,XineramaQueryScreens,[
++ AC_DEFINE(HAVE_LIBXINERAMA, [], [Enable Xinerama support])
++ LIBS="$LIBS -lXext -lXinerama"
++ ])
++ ])
++fi
+ AC_CHECK_LIB(jpeg, jpeg_destroy_decompress)
+
+ dnl AC_CHECK_FUNC(getopt_long,,[AC_LIBOBJ="$AC_LIBOBJ getopt.o getopt1.o"])
+--- feh-1.3.4/src/Makefile.am
++++ feh-1.3.4/src/Makefile.am
+@@ -1,7 +1,6 @@
+ # A list of all the files in the current directory which can be regenerated
+ MAINTAINERCLEANFILES = Makefile.in
+
+-LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib -lz -lpng
+ INCLUDES = -I/usr/X11R6/include $(X_CFLAGS) \
+ -I$(prefix)/include -I$(includedir) \
+ -I. -I$(top_srcdir)/src \