summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-12 18:29:50 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-12 18:29:50 +0000
commitb8bb765a6ab65a8d1ed7718ea52caa9e3366df6b (patch)
treebae1041daa9187b3a913755e14c87013e70bb1e4 /gnome-base/libgnomekbd
parentCleanup (diff)
downloadgentoo-2-b8bb765a6ab65a8d1ed7718ea52caa9e3366df6b.tar.gz
gentoo-2-b8bb765a6ab65a8d1ed7718ea52caa9e3366df6b.tar.bz2
gentoo-2-b8bb765a6ab65a8d1ed7718ea52caa9e3366df6b.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/libgnomekbd')
-rw-r--r--gnome-base/libgnomekbd/ChangeLog11
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild38
2 files changed, 48 insertions, 1 deletions
diff --git a/gnome-base/libgnomekbd/ChangeLog b/gnome-base/libgnomekbd/ChangeLog
index 117a8d097149..71406b1ac370 100644
--- a/gnome-base/libgnomekbd/ChangeLog
+++ b/gnome-base/libgnomekbd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-base/libgnomekbd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/ChangeLog,v 1.80 2010/10/07 21:49:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/ChangeLog,v 1.81 2010/10/12 18:29:50 pacho Exp $
+
+*libgnomekbd-2.32.0 (12 Oct 2010)
+
+ 12 Oct 2010; Pacho Ramos <pacho@gentoo.org> +libgnomekbd-2.32.0.ebuild:
+ Version bump for Gnome 2.32: Some rendering switched to Cairo, other
+ rendering improvements, updated translations. FreeBSD is supposed to have
+ problems with parallel building but it's not clear if they are still valid
+ and upstream wasn't ever notified, this will build in parallel also for
+ them, if you suffer any problem, please open a bug report.
07 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
libgnomekbd-2.30.2.ebuild:
diff --git a/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild b/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild
new file mode 100644
index 000000000000..a5e83907f3b9
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild,v 1.1 2010/10/12 18:29:50 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+# gtk+-2.20 needed for tests
+RDEPEND=">=dev-libs/glib-2.18
+ >=gnome-base/gconf-2.14
+ >=x11-libs/gtk+-2.20
+ >=x11-libs/libxklavier-5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable test tests) --disable-static"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+#src_compile() {
+ # FreeBSD doesn't like -j, upstream? bug #176517
+ # FIXME: Please re-test and notify us if still valid,
+ # disabling for now
+ # use x86-fbsd && MAKEOPTS="${MAKEOPTS} -j1"
+# gnome2_src_compile
+#}