summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild')
-rw-r--r--gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild b/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild
new file mode 100644
index 000000000000..a5e83907f3b9
--- /dev/null
+++ b/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomekbd/libgnomekbd-2.32.0.ebuild,v 1.1 2010/10/12 18:29:50 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Gnome keyboard configuration library"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+
+# gtk+-2.20 needed for tests
+RDEPEND=">=dev-libs/glib-2.18
+ >=gnome-base/gconf-2.14
+ >=x11-libs/gtk+-2.20
+ >=x11-libs/libxklavier-5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable test tests) --disable-static"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+#src_compile() {
+ # FreeBSD doesn't like -j, upstream? bug #176517
+ # FIXME: Please re-test and notify us if still valid,
+ # disabling for now
+ # use x86-fbsd && MAKEOPTS="${MAKEOPTS} -j1"
+# gnome2_src_compile
+#}