summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-01-02 20:40:19 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2014-01-02 20:40:19 +0000
commit7e8ee3393224e3409829478b52a5715ef794588b (patch)
tree9e8813e542df023840e6bf712a5c0d1092a9ead6 /dev-util/catalyst
parentversion bump wrt bug #495152 (diff)
downloadgentoo-2-7e8ee3393224e3409829478b52a5715ef794588b.tar.gz
gentoo-2-7e8ee3393224e3409829478b52a5715ef794588b.tar.bz2
gentoo-2-7e8ee3393224e3409829478b52a5715ef794588b.zip
Synchonize release and live ebuilds (2.9999 is special as it's tracking the 3.0 branch that provides a python install). 2.0.15 and earlier will be dropped when 2.0.16 is added to the tree.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BB0E6E98)
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.15.ebuild76
-rw-r--r--dev-util/catalyst/catalyst-2.9999.ebuild48
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild75
4 files changed, 123 insertions, 84 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index e72d1835f791..1a808ecc707a 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.268 2014/01/02 20:30:23 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.269 2014/01/02 20:40:19 jmbsvicetto Exp $
+
+ 02 Jan 2014; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ catalyst-2.0.15.ebuild, catalyst-2.9999.ebuild, catalyst-9999.ebuild:
+ Synchonize release and live ebuilds (2.9999 is special as it's tracking the
+ 3.0 branch that provides a python install). 2.0.15 and earlier will be dropped
+ when 2.0.16 is added to the tree.
*catalyst-2.0.9999 (02 Jan 2014)
diff --git a/dev-util/catalyst/catalyst-2.0.15.ebuild b/dev-util/catalyst/catalyst-2.0.15.ebuild
index fd32b3a11047..6d244fa39880 100644
--- a/dev-util/catalyst/catalyst-2.0.15.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.15.ebuild
@@ -1,40 +1,52 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.15.ebuild,v 1.1 2013/11/14 00:46:40 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.15.ebuild,v 1.2 2014/01/02 20:40:19 jmbsvicetto Exp $
-EAPI=3
-PYTHON_DEPEND="2"
+EAPI=5
if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
+ EGIT_MASTER="master"
SRC_URI=""
- S="${WORKDIR}/${PN}"
KEYWORDS=""
+ S="${WORKDIR}/${PN}"
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2"
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
-inherit eutils multilib python
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-single-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
LICENSE="GPL-2"
SLOT="0"
-RESTRICT=""
IUSE="ccache kernel_linux"
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
+DEPEND="
+ app-text/asciidoc
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ app-arch/lbzip2
app-crypt/shash
virtual/cdrtools
- x86? ( >=sys-boot/syslinux-3.72 )
amd64? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
pkg_setup() {
if use ccache ; then
@@ -44,39 +56,41 @@ pkg_setup() {
ewarn "If this is not what you intended,"
ewarn "then you should add ccache to your USE."
fi
+
echo
einfo "The template spec files are now installed by default. You can find"
einfo "them under /usr/share/doc/${PF}/examples"
einfo "and they are considered to be the authorative source of information"
einfo "on catalyst."
echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
+ python-single-r1_pkg_setup
}
src_install() {
insinto /usr/$(get_libdir)/${PN}
exeinto /usr/$(get_libdir)/${PN}
doexe catalyst || die "copying catalyst"
+
if [[ ${PV} == 3.9999* ]]; then
doins -r modules files || die "copying files"
else
doins -r arch modules livecd || die "copying files"
fi
+
for x in targets/*; do
exeinto /usr/$(get_libdir)/${PN}/$x
doexe $x/* || die "copying ${x}"
done
+
+ # Here is where we actually enable ccache
+ use ccache && \
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
+ files/catalyst.conf
+
+ sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ files/catalyst.conf
+
make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
insinto /etc/catalyst
doins files/catalyst.conf files/catalystrc || die "copying configuration"
@@ -84,17 +98,13 @@ src_install() {
doins examples/* || die
dodoc README AUTHORS
doman files/catalyst.1 files/catalyst-spec.5
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
+
+ python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
+ python_optimize "${ED}"
}
pkg_postinst() {
einfo "You can find more information about catalyst by checking out the"
einfo "catalyst project page at:"
einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
}
diff --git a/dev-util/catalyst/catalyst-2.9999.ebuild b/dev-util/catalyst/catalyst-2.9999.ebuild
index b451ee767753..43be43a27b45 100644
--- a/dev-util/catalyst/catalyst-2.9999.ebuild
+++ b/dev-util/catalyst/catalyst-2.9999.ebuild
@@ -1,35 +1,49 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.9999.ebuild,v 1.11 2013/06/16 14:58:39 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.9999.ebuild,v 1.12 2014/01/02 20:40:19 jmbsvicetto Exp $
-EAPI="5"
+EAPI=5
+
+if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ EGIT_MASTER="master"
+ EGIT_BRANCH="3.0"
+ SRC_URI=""
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit distutils-r1 git-2
+inherit distutils-r1 multilib ${SRC_ECLASS}
-DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux."
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
-EGIT_MASTER="master"
-EGIT_BRANCH="3.0"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
IUSE="ccache doc kernel_linux"
-KEYWORDS=""
-
-DEPEND="app-text/asciidoc
- >=dev-python/snakeoil-0.5.2"
-
-RDEPEND="app-arch/lbzip2
+DEPEND="
+ app-text/asciidoc
+ >=dev-python/snakeoil-0.5.2
+"
+RDEPEND="
+ app-arch/lbzip2
app-crypt/shash
virtual/cdrtools
- ccache? ( dev-util/ccache )
+ amd64? ( >=sys-boot/syslinux-3.72 )
ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+"
python_prepare_all() {
python_export_best
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index f48fd24f732e..96903025c0d9 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,40 +1,51 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.29 2013/07/31 04:34:00 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.30 2014/01/02 20:40:19 jmbsvicetto Exp $
-EAPI=3
-PYTHON_DEPEND="2"
+EAPI=5
if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
+ EGIT_MASTER="master"
SRC_URI=""
- S="${WORKDIR}/${PN}"
KEYWORDS=""
+ S="${WORKDIR}/${PN}"
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
-inherit eutils multilib python
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-single-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
LICENSE="GPL-2"
SLOT="0"
-RESTRICT=""
IUSE="ccache kernel_linux"
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
+DEPEND="
+ app-text/asciidoc
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ app-arch/lbzip2
app-crypt/shash
virtual/cdrtools
- x86? ( >=sys-boot/syslinux-3.72 )
amd64? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
pkg_setup() {
if use ccache ; then
@@ -44,39 +55,41 @@ pkg_setup() {
ewarn "If this is not what you intended,"
ewarn "then you should add ccache to your USE."
fi
+
echo
einfo "The template spec files are now installed by default. You can find"
einfo "them under /usr/share/doc/${PF}/examples"
einfo "and they are considered to be the authorative source of information"
einfo "on catalyst."
echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
+ python-single-r1_pkg_setup
}
src_install() {
insinto /usr/$(get_libdir)/${PN}
exeinto /usr/$(get_libdir)/${PN}
doexe catalyst || die "copying catalyst"
+
if [[ ${PV} == 3.9999* ]]; then
doins -r modules files || die "copying files"
else
doins -r arch modules livecd || die "copying files"
fi
+
for x in targets/*; do
exeinto /usr/$(get_libdir)/${PN}/$x
doexe $x/* || die "copying ${x}"
done
+
+ # Here is where we actually enable ccache
+ use ccache && \
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
+ files/catalyst.conf
+
+ sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ files/catalyst.conf
+
make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
insinto /etc/catalyst
doins files/catalyst.conf files/catalystrc || die "copying configuration"
@@ -84,17 +97,13 @@ src_install() {
doins examples/* || die
dodoc README AUTHORS
doman files/catalyst.1 files/catalyst-spec.5
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
+
+ python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
+ python_optimize "${ED}"
}
pkg_postinst() {
einfo "You can find more information about catalyst by checking out the"
einfo "catalyst project page at:"
einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
}