summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/catalyst/catalyst-9999.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-9999.ebuild75
1 files changed, 42 insertions, 33 deletions
diff --git a/dev-util/catalyst/catalyst-9999.ebuild b/dev-util/catalyst/catalyst-9999.ebuild
index f48fd24f732e..96903025c0d9 100644
--- a/dev-util/catalyst/catalyst-9999.ebuild
+++ b/dev-util/catalyst/catalyst-9999.ebuild
@@ -1,40 +1,51 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.29 2013/07/31 04:34:00 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-9999.ebuild,v 1.30 2014/01/02 20:40:19 jmbsvicetto Exp $
-EAPI=3
-PYTHON_DEPEND="2"
+EAPI=5
if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
+ EGIT_MASTER="master"
SRC_URI=""
- S="${WORKDIR}/${PN}"
KEYWORDS=""
+ S="${WORKDIR}/${PN}"
else
SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
-inherit eutils multilib python
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils multilib python-single-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
LICENSE="GPL-2"
SLOT="0"
-RESTRICT=""
IUSE="ccache kernel_linux"
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
+DEPEND="
+ app-text/asciidoc
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ app-arch/lbzip2
app-crypt/shash
virtual/cdrtools
- x86? ( >=sys-boot/syslinux-3.72 )
amd64? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
pkg_setup() {
if use ccache ; then
@@ -44,39 +55,41 @@ pkg_setup() {
ewarn "If this is not what you intended,"
ewarn "then you should add ccache to your USE."
fi
+
echo
einfo "The template spec files are now installed by default. You can find"
einfo "them under /usr/share/doc/${PF}/examples"
einfo "and they are considered to be the authorative source of information"
einfo "on catalyst."
echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
+ python-single-r1_pkg_setup
}
src_install() {
insinto /usr/$(get_libdir)/${PN}
exeinto /usr/$(get_libdir)/${PN}
doexe catalyst || die "copying catalyst"
+
if [[ ${PV} == 3.9999* ]]; then
doins -r modules files || die "copying files"
else
doins -r arch modules livecd || die "copying files"
fi
+
for x in targets/*; do
exeinto /usr/$(get_libdir)/${PN}/$x
doexe $x/* || die "copying ${x}"
done
+
+ # Here is where we actually enable ccache
+ use ccache && \
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
+ files/catalyst.conf
+
+ sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ files/catalyst.conf
+
make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
insinto /etc/catalyst
doins files/catalyst.conf files/catalystrc || die "copying configuration"
@@ -84,17 +97,13 @@ src_install() {
doins examples/* || die
dodoc README AUTHORS
doman files/catalyst.1 files/catalyst-spec.5
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
+
+ python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
+ python_optimize "${ED}"
}
pkg_postinst() {
einfo "You can find more information about catalyst by checking out the"
einfo "catalyst project page at:"
einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
}