summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-07-28 21:43:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-07-28 21:43:11 +0000
commit8f4120db7b1dcc96a342532e933cf4040bee2d8f (patch)
treea459e7826187cfaf11460fc6662772e128dfa8bb /dev-python/wxpython
parent QA: Get rid of deprecated qt_min_version(). Please fix your ebuilds to suppo... (diff)
downloadgentoo-2-8f4120db7b1dcc96a342532e933cf4040bee2d8f.tar.gz
gentoo-2-8f4120db7b1dcc96a342532e933cf4040bee2d8f.tar.bz2
gentoo-2-8f4120db7b1dcc96a342532e933cf4040bee2d8f.zip
Work around aliasing bug in GCC 4.1 by building with -fno-strict-aliasing.
Manifested as 'TypeError: wx.Window, wx.Sizer, wx.Size, or (w,h) expected for item' errors in various apps. Bug #233154, reported by Henrik Sankala. (Portage version: 2.2_rc3/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog11
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.8.7.1.ebuild6
-rw-r--r--dev-python/wxpython/wxpython-2.8.8.1.ebuild6
5 files changed, 26 insertions, 9 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 5b7a89014c84..739bd5d2ae04 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.89 2008/07/25 02:44:24 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.90 2008/07/28 21:43:11 dirtyepic Exp $
+
+ 28 Jul 2008; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.6.4.0.ebuild,
+ wxpython-2.6.4.0-r1.ebuild, wxpython-2.8.7.1.ebuild,
+ wxpython-2.8.8.1.ebuild:
+ Work around aliasing bug in GCC 4.1 by building with -fno-strict-aliasing.
+ Manifested as 'TypeError: wx.Window, wx.Sizer, wx.Size, or (w,h) expected
+ for item' errors in various apps.
+
+ Bug #233154, reported by Henrik Sankala.
*wxpython-2.8.8.1 (25 Jul 2008)
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index e69b59a0b61e..054a7f716b6a 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.14 2008/05/29 16:40:05 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.15 2008/07/28 21:43:11 dirtyepic Exp $
EAPI=1
-inherit alternatives eutils multilib python wxwidgets
+inherit alternatives eutils multilib python wxwidgets flag-o-matic
# Note, we don't use distutils.eclass because it doesn't seem to play nice with
# need-wxwidgets
@@ -54,6 +54,8 @@ src_compile() {
use opengl && check_wxuse opengl
+ append-flags -fno-strict-aliasing
+
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
diff --git a/dev-python/wxpython/wxpython-2.6.4.0.ebuild b/dev-python/wxpython/wxpython-2.6.4.0.ebuild
index 66f3143d0d68..f0464139bc3d 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0.ebuild,v 1.13 2008/01/10 09:43:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0.ebuild,v 1.14 2008/07/28 21:43:11 dirtyepic Exp $
-inherit python wxwidgets eutils multilib
+inherit python wxwidgets eutils multilib flag-o-matic
MY_P="${P/wxpython-/wxPython-src-}"
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
@@ -55,6 +55,8 @@ src_compile() {
need-wxwidgets gtk2
fi
+ append-flags -fno-strict-aliasing
+
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
diff --git a/dev-python/wxpython/wxpython-2.8.7.1.ebuild b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
index 27c69aeaa1d6..9f35c2883b6d 100644
--- a/dev-python/wxpython/wxpython-2.8.7.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.7.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.11 2008/05/29 16:40:05 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.7.1.ebuild,v 1.12 2008/07/28 21:43:11 dirtyepic Exp $
EAPI="1"
WX_GTK_VER="2.8"
-inherit alternatives eutils multilib python wxwidgets
+inherit alternatives eutils multilib python wxwidgets flag-o-matic
# Note, we don't use distutils.eclass because it doesn't seem to play nice with
# need-wxwidgets
@@ -50,6 +50,8 @@ src_compile() {
need-wxwidgets unicode
use opengl && check_wxuse opengl
+ append-flags -fno-strict-aliasing
+
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
diff --git a/dev-python/wxpython/wxpython-2.8.8.1.ebuild b/dev-python/wxpython/wxpython-2.8.8.1.ebuild
index 73d99c71719b..ba504cac4a44 100644
--- a/dev-python/wxpython/wxpython-2.8.8.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.8.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.8.1.ebuild,v 1.1 2008/07/25 02:44:24 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.8.1.ebuild,v 1.2 2008/07/28 21:43:11 dirtyepic Exp $
EAPI="1"
WX_GTK_VER="2.8"
-inherit alternatives eutils multilib python wxwidgets
+inherit alternatives eutils multilib python wxwidgets flag-o-matic
# Note, we don't use distutils.eclass because it doesn't seem to play nice with
# need-wxwidgets
@@ -52,6 +52,8 @@ src_compile() {
need-wxwidgets unicode
use opengl && check_wxuse opengl
+ append-flags -fno-strict-aliasing
+
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \