summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
index e69b59a0b61e..054a7f716b6a 100644
--- a/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.14 2008/05/29 16:40:05 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.6.4.0-r1.ebuild,v 1.15 2008/07/28 21:43:11 dirtyepic Exp $
EAPI=1
-inherit alternatives eutils multilib python wxwidgets
+inherit alternatives eutils multilib python wxwidgets flag-o-matic
# Note, we don't use distutils.eclass because it doesn't seem to play nice with
# need-wxwidgets
@@ -54,6 +54,8 @@ src_compile() {
use opengl && check_wxuse opengl
+ append-flags -fno-strict-aliasing
+
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \