summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-08-30 11:59:52 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-08-30 11:59:52 +0000
commit5eb3883e9003a5fc16e432693cd3ab4c094f4faa (patch)
treef2538985faa5b9008b5503f974a1d24994fb01df /dev-python/stomper
parentVersion bump per #283204, and fix deps and location of config files (diff)
downloadgentoo-2-5eb3883e9003a5fc16e432693cd3ab4c094f4faa.tar.gz
gentoo-2-5eb3883e9003a5fc16e432693cd3ab4c094f4faa.tar.bz2
gentoo-2-5eb3883e9003a5fc16e432693cd3ab4c094f4faa.zip
bump stomper to remove internal uuid dep per #283199
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-python/stomper')
-rw-r--r--dev-python/stomper/ChangeLog8
-rw-r--r--dev-python/stomper/files/stomper-0.2.2-dont_require_separate_uuid_package.patch21
-rw-r--r--dev-python/stomper/stomper-0.2.2-r1.ebuild26
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/stomper/ChangeLog b/dev-python/stomper/ChangeLog
index 61cace5a7ce6..926e0aad8199 100644
--- a/dev-python/stomper/ChangeLog
+++ b/dev-python/stomper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/stomper
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/stomper/ChangeLog,v 1.3 2009/08/30 02:30:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stomper/ChangeLog,v 1.4 2009/08/30 11:59:52 caleb Exp $
+
+*stomper-0.2.2-r1 (30 Aug 2009)
+
+ 30 Aug 2009; Caleb Tennis <caleb@gentoo.org> +stomper-0.2.2-r1.ebuild,
+ +files/stomper-0.2.2-dont_require_separate_uuid_package.patch:
+ bump stomper to remove uuid dep per #283199
*stomper-0.2.2 (19 Apr 2009)
diff --git a/dev-python/stomper/files/stomper-0.2.2-dont_require_separate_uuid_package.patch b/dev-python/stomper/files/stomper-0.2.2-dont_require_separate_uuid_package.patch
new file mode 100644
index 000000000000..58cee7408fb7
--- /dev/null
+++ b/dev-python/stomper/files/stomper-0.2.2-dont_require_separate_uuid_package.patch
@@ -0,0 +1,21 @@
+--- setup.py
++++ setup.py
+@@ -45,10 +45,6 @@
+ }
+
+
+-needed = [
+- 'uuid>=1.2',
+-]
+-
+ setup(
+ # url=ProjecUrl,
+ name=Name,
+@@ -60,7 +56,6 @@
+ url=ProjecUrl,
+ license=License,
+ classifiers=Classifiers,
+- install_requires=needed,
+ test_suite=TestSuite,
+ scripts=ProjectScripts,
+ packages=find_packages('lib'),
diff --git a/dev-python/stomper/stomper-0.2.2-r1.ebuild b/dev-python/stomper/stomper-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..f4ae79c105b9
--- /dev/null
+++ b/dev-python/stomper/stomper-0.2.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/stomper/stomper-0.2.2-r1.ebuild,v 1.1 2009/08/30 11:59:52 caleb Exp $
+
+EAPI="2"
+#SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="This is a transport neutral client implementation of the STOMP protocol."
+HOMEPAGE="http://pypi.python.org/pypi/stomper"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-dont_require_separate_uuid_package.patch"
+}