summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-28 19:17:39 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-28 19:17:39 +0000
commit055b6f57cf33d96f9e5c0a1a3abb3c3a4bba1978 (patch)
treeb1c84952b78c79d753c8fd12c970332b0f2800e2 /dev-games/clanlib
parentSwitch to CPU_FLAGS_X86. (diff)
downloadgentoo-2-055b6f57cf33d96f9e5c0a1a3abb3c3a4bba1978.tar.gz
gentoo-2-055b6f57cf33d96f9e5c0a1a3abb3c3a4bba1978.tar.bz2
gentoo-2-055b6f57cf33d96f9e5c0a1a3abb3c3a4bba1978.zip
Switch to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog8
-rw-r--r--dev-games/clanlib/clanlib-2.3.6.ebuild8
-rw-r--r--dev-games/clanlib/clanlib-2.3.7.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 69dd72a3001c..3d41f6d816da 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/clanlib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.65 2014/09/12 19:12:38 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.66 2015/01/28 19:17:39 mgorny Exp $
+
+ 28 Jan 2015; Michał Górny <mgorny@gentoo.org> clanlib-2.3.6.ebuild,
+ clanlib-2.3.7.ebuild:
+ Switch to CPU_FLAGS_X86.
12 Sep 2014; Tupone Alfredo <tupone@gentoo.org> clanlib-2.3.7.ebuild,
+files/clanlib-2.3.7-doc.patch:
diff --git a/dev-games/clanlib/clanlib-2.3.6.ebuild b/dev-games/clanlib/clanlib-2.3.6.ebuild
index d7487c4223dd..5f8b7cf909c5 100644
--- a/dev-games/clanlib/clanlib-2.3.6.ebuild
+++ b/dev-games/clanlib/clanlib-2.3.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.6.ebuild,v 1.5 2013/10/28 23:31:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.6.ebuild,v 1.6 2015/01/28 19:17:39 mgorny Exp $
EAPI=4
inherit flag-o-matic eutils autotools-utils
@@ -14,7 +14,7 @@ SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
LICENSE="ZLIB"
SLOT="2.3"
KEYWORDS="amd64 x86" #not big endian safe #82779
-IUSE="doc ipv6 mikmod opengl sound sqlite sse2 static-libs vorbis X"
+IUSE="doc ipv6 mikmod opengl sound sqlite cpu_flags_x86_sse2 static-libs vorbis X"
REQUIRED_USE="opengl? ( X )"
RDEPEND="sys-libs/zlib
@@ -57,7 +57,7 @@ DOCS=(
src_configure() {
myeconfargs=(
$(use_enable doc docs)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_sse2 sse2)
$(use_enable opengl clanGL)
$(use_enable opengl clanGL1)
$(use_enable opengl clanGUI)
diff --git a/dev-games/clanlib/clanlib-2.3.7.ebuild b/dev-games/clanlib/clanlib-2.3.7.ebuild
index 9d7c5ad5f18f..2f059cd4068a 100644
--- a/dev-games/clanlib/clanlib-2.3.7.ebuild
+++ b/dev-games/clanlib/clanlib-2.3.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.7.ebuild,v 1.2 2014/09/12 19:12:38 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.7.ebuild,v 1.3 2015/01/28 19:17:39 mgorny Exp $
EAPI=4
inherit flag-o-matic eutils autotools-utils
@@ -14,7 +14,7 @@ SRC_URI="http://clanlib.org/download/releases-2.0/${MY_P}.tgz"
LICENSE="ZLIB"
SLOT="2.3"
KEYWORDS="~amd64 ~x86" #not big endian safe #82779
-IUSE="doc ipv6 mikmod opengl sound sqlite sse2 static-libs vorbis X"
+IUSE="doc ipv6 mikmod opengl sound sqlite cpu_flags_x86_sse2 static-libs vorbis X"
REQUIRED_USE="opengl? ( X )"
RDEPEND="sys-libs/zlib
@@ -65,7 +65,7 @@ src_prepare() {
src_configure() {
myeconfargs=(
$(use_enable doc docs)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_sse2 sse2)
$(use_enable opengl clanGL)
$(use_enable opengl clanGL1)
$(use_enable opengl clanGUI)