summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:41 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:41 +0000
commitd0f86b932d4ed92834b530ab434203fc5139ef9a (patch)
treea4bd1d7594c538191cc7241bf2d26ffe5c169656 /app-editors/xvile
parent (Manifest recommit) (diff)
downloadgentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.tar.gz
gentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.tar.bz2
gentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.zip
add inherit eutils
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/xvile-9.4d.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/app-editors/xvile/xvile-9.4d.ebuild b/app-editors/xvile/xvile-9.4d.ebuild
index 3e53a04ae45a..60457467d231 100644
--- a/app-editors/xvile/xvile-9.4d.ebuild
+++ b/app-editors/xvile/xvile-9.4d.ebuild
@@ -1,48 +1,49 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.4d.ebuild,v 1.1 2004/03/03 15:37:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.4d.ebuild,v 1.2 2004/04/06 03:45:14 vapier Exp $
-IUSE="perl"
+inherit eutils
S=${WORKDIR}/vile-9.4
DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
SRC_URI="ftp://ftp.phred.org/pub/vile/vile-9.4.tgz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4a.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4b.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4c.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4d.patch.gz"
-HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc alpha ia64"
+IUSE="perl"
RDEPEND="perl? ( dev-lang/perl )
virtual/x11
=app-editors/vile-${PVR}"
-
DEPEND="${RDEPEND}
sys-devel/flex"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc alpha ia64"
-
src_unpack() {
- local p
-
unpack vile-9.4.tgz
cd ${S} || die "cd failed"
+ local p
for p in ${DISTDIR}/vile-${PV%[a-z]}[a-${P##*[0-9]}].patch.gz; do
epatch ${p} || die "epatch failed"
done
}
src_compile() {
- econf --with-ncurses --with-x \
- `use_with perl` || die "configure failed"
+ econf \
+ --with-ncurses \
+ --with-x \
+ `use_with perl` \
+ || die "configure failed"
emake || die "emake failed"
}
-src_install () {
- dobin xvile
- dodoc CHANGES* COPYING MANIFEST INSTALL README* doc/*
+src_install() {
+ dobin xvile || die
+ dodoc CHANGES* INSTALL README* doc/*
}