summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:41 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:45:41 +0000
commitd0f86b932d4ed92834b530ab434203fc5139ef9a (patch)
treea4bd1d7594c538191cc7241bf2d26ffe5c169656
parent (Manifest recommit) (diff)
downloadgentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.tar.gz
gentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.tar.bz2
gentoo-2-d0f86b932d4ed92834b530ab434203fc5139ef9a.zip
add inherit eutils
-rw-r--r--app-editors/mp/mp-3.2.11.ebuild32
-rw-r--r--app-editors/vile/vile-9.4d.ebuild34
-rw-r--r--app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild4
-rw-r--r--app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.4.10-r1.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.4.10-r2.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.4.10.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.4.11.ebuild4
-rw-r--r--app-editors/xemacs/xemacs-21.4.9.ebuild4
-rw-r--r--app-editors/xvile/xvile-9.4d.ebuild31
-rw-r--r--app-emacs/ecb/ecb-1.96.ebuild12
11 files changed, 76 insertions, 61 deletions
diff --git a/app-editors/mp/mp-3.2.11.ebuild b/app-editors/mp/mp-3.2.11.ebuild
index 323e1297dcb2..de87b2d25151 100644
--- a/app-editors/mp/mp-3.2.11.ebuild
+++ b/app-editors/mp/mp-3.2.11.ebuild
@@ -1,36 +1,40 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.2 2004/03/13 22:30:28 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.3 2004/04/06 03:42:07 vapier Exp $
+
+inherit eutils
DESCRIPTION="mp, the definitive text editor"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
-HOMEPAGE="http://www.triptico.com/software/mp.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="ncurses gtk"
DEPEND="virtual/glibc
ncurses? ( sys-libs/ncurses )
- gtk? ( =x11-libs/gtk+-1.2* )"
-
+ gtk? ( =x11-libs/gtk+-1.2* )
+ !gtk? ( sys-libs/ncurses )"
RDEPEND="${DEPEND}
dev-lang/perl"
-IUSE="ncurses gtk"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc"
src_compile() {
epatch ${FILESDIR}/gentoo-synh-mp.patch-3.2.11
- if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
- elif [ -n "`use ncurses`" ]; then emake mp || die;
- elif [ -n "`use gtk`" ]; then emake gmp || die;
- else die "You need ncurses and/or gtk in your USE variables";
+ if use ncurses && use gtk ; then
+ emake || die "make failed"
+ elif use gtk ; then
+ emake gmp || die "make gmp failed"
+ else
+ emake mp || die "make mp failed"
fi
}
-src_install () {
+src_install() {
dodir /usr/bin
make install PREFIX=${D}/usr || die "install failed"
- dodoc AUTHORS Changelog COPYING README
+ dodoc AUTHORS Changelog README
dohtml README.html doc/mp_api.html
insinto /usr/share/pixmaps/
doins mp.xpm
diff --git a/app-editors/vile/vile-9.4d.ebuild b/app-editors/vile/vile-9.4d.ebuild
index 7f9781bf7ac5..5ff6ded67478 100644
--- a/app-editors/vile/vile-9.4d.ebuild
+++ b/app-editors/vile/vile-9.4d.ebuild
@@ -1,50 +1,48 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.4d.ebuild,v 1.3 2004/03/03 17:40:50 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.4d.ebuild,v 1.4 2004/04/06 03:43:03 vapier Exp $
-IUSE="perl"
+inherit eutils
S=${WORKDIR}/vile-9.4
DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
SRC_URI="ftp://ftp.phred.org/pub/vile/vile-9.4.tgz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4a.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4b.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4c.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4d.patch.gz"
-HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
-
-DEPEND="${RDEPEND}
- sys-devel/flex"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha ia64"
+IUSE="perl"
RDEPEND=">=sys-libs/ncurses-5.2
perl? ( dev-lang/perl )"
-
+DEPEND="${RDEPEND}
+ sys-devel/flex"
PROVIDE="virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc alpha ia64"
-
src_unpack() {
- local p
-
unpack vile-9.4.tgz
cd ${S}
+ local p
for p in ${DISTDIR}/${P%[a-z]}[a-${P##*[0-9]}].patch.gz; do
epatch ${p} || die "epatch failed"
done
}
src_compile() {
- econf --with-ncurses \
- `use_with perl` || die "configure failed"
+ econf \
+ --with-ncurses \
+ `use_with perl` \
+ || die "configure failed"
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "install failed"
- dodoc CHANGES* COPYING MANIFEST INSTALL README* doc/*
+ dodoc CHANGES* INSTALL README* doc/*
}
-
diff --git a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
index 33eafdc65ff3..3315f6804e31 100644
--- a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
+++ b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild,v 1.13 2004/01/22 22:07:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild,v 1.14 2004/04/06 03:43:18 vapier Exp $
+
+inherit eutils
IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
diff --git a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
index 3296acecdaba..f212039fb6f4 100644
--- a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
+++ b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild,v 1.15 2004/01/22 22:07:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild,v 1.16 2004/04/06 03:43:33 vapier Exp $
+
+inherit eutils
IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
diff --git a/app-editors/xemacs/xemacs-21.4.10-r1.ebuild b/app-editors/xemacs/xemacs-21.4.10-r1.ebuild
index 352b7820fc03..27437930fe2a 100644
--- a/app-editors/xemacs/xemacs-21.4.10-r1.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.10-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.10-r1.ebuild,v 1.9 2004/03/30 02:40:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.10-r1.ebuild,v 1.10 2004/04/06 03:43:44 vapier Exp $
+
+inherit eutils
IUSE="gpm postgres xface nas dnd X jpeg tiff png mule motif canna freewnn lucid athena neXt Xaw3d"
diff --git a/app-editors/xemacs/xemacs-21.4.10-r2.ebuild b/app-editors/xemacs/xemacs-21.4.10-r2.ebuild
index bb2e786861d3..4712a7c670c4 100644
--- a/app-editors/xemacs/xemacs-21.4.10-r2.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.10-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.10-r2.ebuild,v 1.9 2004/03/30 02:40:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.10-r2.ebuild,v 1.10 2004/04/06 03:43:54 vapier Exp $
+
+inherit eutils
IUSE="gpm postgres xface nas dnd X jpeg tiff png mule motif canna freewnn lucid athena neXt Xaw3d"
diff --git a/app-editors/xemacs/xemacs-21.4.10.ebuild b/app-editors/xemacs/xemacs-21.4.10.ebuild
index 801fab4a59d0..45b465cde01f 100644
--- a/app-editors/xemacs/xemacs-21.4.10.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.10.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.10.ebuild,v 1.11 2004/03/30 02:40:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.10.ebuild,v 1.12 2004/04/06 03:44:00 vapier Exp $
+
+inherit eutils
IUSE="gpm esd postgres xface nas X jpeg tiff png mule motif canna"
diff --git a/app-editors/xemacs/xemacs-21.4.11.ebuild b/app-editors/xemacs/xemacs-21.4.11.ebuild
index 093121cadfde..e2548279e64a 100644
--- a/app-editors/xemacs/xemacs-21.4.11.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.11.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.11.ebuild,v 1.7 2004/01/05 23:35:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.11.ebuild,v 1.8 2004/04/06 03:44:10 vapier Exp $
+
+inherit eutils
IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna lucid athena neXt Xaw3d"
diff --git a/app-editors/xemacs/xemacs-21.4.9.ebuild b/app-editors/xemacs/xemacs-21.4.9.ebuild
index 6ad24ec50475..bf20ca26c33a 100644
--- a/app-editors/xemacs/xemacs-21.4.9.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.13 2004/03/30 02:40:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.14 2004/04/06 03:44:15 vapier Exp $
+
+inherit eutils
IUSE="gpm esd postgres xface nas X jpeg tiff png mule"
diff --git a/app-editors/xvile/xvile-9.4d.ebuild b/app-editors/xvile/xvile-9.4d.ebuild
index 3e53a04ae45a..60457467d231 100644
--- a/app-editors/xvile/xvile-9.4d.ebuild
+++ b/app-editors/xvile/xvile-9.4d.ebuild
@@ -1,48 +1,49 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.4d.ebuild,v 1.1 2004/03/03 15:37:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.4d.ebuild,v 1.2 2004/04/06 03:45:14 vapier Exp $
-IUSE="perl"
+inherit eutils
S=${WORKDIR}/vile-9.4
DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
SRC_URI="ftp://ftp.phred.org/pub/vile/vile-9.4.tgz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4a.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4b.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4c.patch.gz
ftp://ftp.phred.org/pub/vile/patches/vile-9.4d.patch.gz"
-HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc alpha ia64"
+IUSE="perl"
RDEPEND="perl? ( dev-lang/perl )
virtual/x11
=app-editors/vile-${PVR}"
-
DEPEND="${RDEPEND}
sys-devel/flex"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc alpha ia64"
-
src_unpack() {
- local p
-
unpack vile-9.4.tgz
cd ${S} || die "cd failed"
+ local p
for p in ${DISTDIR}/vile-${PV%[a-z]}[a-${P##*[0-9]}].patch.gz; do
epatch ${p} || die "epatch failed"
done
}
src_compile() {
- econf --with-ncurses --with-x \
- `use_with perl` || die "configure failed"
+ econf \
+ --with-ncurses \
+ --with-x \
+ `use_with perl` \
+ || die "configure failed"
emake || die "emake failed"
}
-src_install () {
- dobin xvile
- dodoc CHANGES* COPYING MANIFEST INSTALL README* doc/*
+src_install() {
+ dobin xvile || die
+ dodoc CHANGES* INSTALL README* doc/*
}
diff --git a/app-emacs/ecb/ecb-1.96.ebuild b/app-emacs/ecb/ecb-1.96.ebuild
index 569675b24272..865565d29fc7 100644
--- a/app-emacs/ecb/ecb-1.96.ebuild
+++ b/app-emacs/ecb/ecb-1.96.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-1.96.ebuild,v 1.2 2003/09/22 23:59:00 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ecb/ecb-1.96.ebuild,v 1.3 2004/04/06 03:45:41 vapier Exp $
-inherit elisp
-
-IUSE="java"
+inherit elisp eutils
DESCRIPTION="ECB is a source code browser for Emacs"
HOMEPAGE="http://ecb.sourceforge.net/"
SRC_URI="mirror://sourceforge/ecb/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
+IUSE="java"
DEPEND="virtual/emacs
>=app-emacs/speedbar-0.14_beta4
@@ -19,8 +19,6 @@ DEPEND="virtual/emacs
>=app-emacs/eieio-0.17
java? ( app-emacs/jde )"
-S="${WORKDIR}/${P}"
-
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/ecb-help.el-${P}-gentoo.diff
@@ -30,7 +28,7 @@ src_unpack() {
src_compile() {
local my_loadpath="${SITELISP}/semantic ${SITELISP}/eieio"
- [ "`use java`" ] \
+ use java \
&& my_loadpath="${my_loadpath} ${SITELISP}/elib ${SITELISP}/jde/lisp"
make \
LOADPATH="${my_loadpath}" \