summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-11-01 16:45:58 +0000
committerUlrich Müller <ulm@gentoo.org>2014-11-01 16:45:58 +0000
commit7e6842072f6670e72e1185b966d0f60763409e59 (patch)
tree90f592fd42042cc99490329f268cc208a891497b
parentFix typo in src_configure, EMACS_FLAVOR instead of EMACS_FLAVOUR. (diff)
downloadgentoo-2-7e6842072f6670e72e1185b966d0f60763409e59.tar.gz
gentoo-2-7e6842072f6670e72e1185b966d0f60763409e59.tar.bz2
gentoo-2-7e6842072f6670e72e1185b966d0f60763409e59.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
-rw-r--r--app-emacs/auctex/ChangeLog7
-rw-r--r--app-emacs/auctex/auctex-11.88.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-emacs/auctex/ChangeLog b/app-emacs/auctex/ChangeLog
index fd586938fea6..7dce01cfb10f 100644
--- a/app-emacs/auctex/ChangeLog
+++ b/app-emacs/auctex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/auctex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.127 2014/11/01 16:33:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.128 2014/11/01 16:45:58 ulm Exp $
+
+*auctex-11.88 (01 Nov 2014)
+
+ 01 Nov 2014; Ulrich Müller <ulm@gentoo.org> +auctex-11.88.ebuild:
+ Version bump.
01 Nov 2014; Ulrich Müller <ulm@gentoo.org> auctex-11.87-r1.ebuild:
Fix typo in src_configure, EMACS_FLAVOR instead of EMACS_FLAVOUR.
diff --git a/app-emacs/auctex/auctex-11.88.ebuild b/app-emacs/auctex/auctex-11.88.ebuild
new file mode 100644
index 000000000000..5fa5b3eb2f2e
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.88.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.88.ebuild,v 1.1 2014/11/01 16:45:58 ulm Exp $
+
+EAPI=5
+
+inherit elisp latex-package
+
+DESCRIPTION="Extended support for writing, formatting and using (La)TeX, Texinfo and BibTeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )"
+RDEPEND="${DEPEND}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ elisp_src_prepare
+}
+
+src_configure() {
+ EMACS_NAME=emacs EMACS_FLAVOR=emacs econf --disable-build-dir-test \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable preview-latex preview)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+ dodoc ChangeLog CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}