summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2010-12-07 16:00:31 +0200
committerIskren Slavov <iskren.s@gmail.com>2010-12-07 16:00:31 +0200
commit071c8083ce06294e03b5a7e704e32c0c7389ac9a (patch)
tree4189662e5b9e6209b4dbb0e3d655ddbf7e35ce33 /sys-libs/libuser
parentgo-oo-bin fixes. fluback moved to /opt (diff)
downloadwish-071c8083ce06294e03b5a7e704e32c0c7389ac9a.tar.gz
wish-071c8083ce06294e03b5a7e704e32c0c7389ac9a.tar.bz2
wish-071c8083ce06294e03b5a7e704e32c0c7389ac9a.zip
Added gambas, system-config-users (and it's dependencies)
Diffstat (limited to 'sys-libs/libuser')
-rw-r--r--sys-libs/libuser/Manifest2
-rw-r--r--sys-libs/libuser/libuser-0.56.18.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-libs/libuser/Manifest b/sys-libs/libuser/Manifest
new file mode 100644
index 0000000..82024ab
--- /dev/null
+++ b/sys-libs/libuser/Manifest
@@ -0,0 +1,2 @@
+DIST libuser-0.56.18.tar.xz 683024 RMD160 ae1cf74c4ab0a54309ad24f4b2f58a8938f85cd7 SHA1 3cdeacea575dbfc80b86fe838dd5639606df123b SHA256 fc23d744f6853c213adb619cfb5b22c49a9ea8a5a75a1e4121f71b28cffa3a74
+EBUILD libuser-0.56.18.ebuild 850 RMD160 8e2205f3fa2f95f368124f31f6b6b44262b6ae15 SHA1 0dbf98726d004447a78a5cd6f109fa9dae84ed19 SHA256 50f5c4c4bce1b16581a17dcae188e586656b69d5240bc9048b21c561b2a6d384
diff --git a/sys-libs/libuser/libuser-0.56.18.ebuild b/sys-libs/libuser/libuser-0.56.18.ebuild
new file mode 100644
index 0000000..4468b3b
--- /dev/null
+++ b/sys-libs/libuser/libuser-0.56.18.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+inherit base eutils
+
+DESCRIPTION="The libuser library implements a standardized interface for manipulating and administering user and group accounts."
+HOMEPAGE="https://fedorahosted.org/libuser"
+SRC_URI="https://fedorahosted.org/releases/l/i/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="ldap +popt sasl selinux"
+COMMON_DEPEND="dev-libs/glib:2
+ ldap? ( net-nds/openldap )
+ popt? ( dev-libs/popt )
+ sasl? ( dev-libs/cyrus-sasl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="app-text/linuxdoc-tools
+ sys-devel/bison
+ sys-devel/gettext
+ ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ cd "${S}"
+ econf $(use_with ldap) $(use_with popt) $(use_with sasl) \
+ $(use_with selinux) --with-python
+}