aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jemalloc/jemalloc-4.2.1.ebuild')
-rw-r--r--dev-libs/jemalloc/jemalloc-4.2.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-libs/jemalloc/jemalloc-4.2.1.ebuild b/dev-libs/jemalloc/jemalloc-4.2.1.ebuild
deleted file mode 100644
index 8951d34d..00000000
--- a/dev-libs/jemalloc/jemalloc-4.2.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: 8c320ea1c37f32ac8644494e4f61a5b343e2d6cd $
-
-EAPI=6
-
-inherit toolchain-funcs multilib-build
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://www.canonware.com/jemalloc/"
-SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="debug static-libs stats"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
- "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
-)
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
-# but jemalloc doesn't implement them in its configure; need this here to
-# supress the warnings until automagic is removed from the eclass
-QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable debug)
- $(use_enable stats)
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- use static-libs || find "${ED}" -name '*.a' -delete
-}