summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dnspython3/dnspython3-1.10.0.ebuild')
-rw-r--r--dev-python/dnspython3/dnspython3-1.10.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/dnspython3/dnspython3-1.10.0.ebuild b/dev-python/dnspython3/dnspython3-1.10.0.ebuild
new file mode 100644
index 0000000..7e51add
--- /dev/null
+++ b/dev-python/dnspython3/dnspython3-1.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+PYTHON_DEPEND="3"
+RESTRICT_PYTHON_ABIS="2.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="DNS toolkit for Python 3"
+HOMEPAGE="http://www.dnspython.org/ http://pypi.python.org/pypi/dnspython3"
+SRC_URI="http://www.dnspython.org/kits3/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+DEPEND="dev-python/pycrypto"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README"
+PYTHON_MODNAME="dns"
+
+src_test() {
+ cd tests
+
+ testing() {
+ local exit_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || exit_status="1"
+ done
+ return "${exit_status}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die "Installation of examples failed"
+ fi
+}