summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-08-12 15:11:31 +0200
committerSven Eden <sven.eden@prydeworx.com>2021-08-12 15:11:31 +0200
commit9c639b97b7117799f34c4fe086170a9bdd507974 (patch)
tree10309a60086b006c8c42caba58982ad4d7468a8d /net-mail
parentmedia-video/shotcut: Bump to 21.06.29 (Second bug fix release) (diff)
downloadseden-9c639b97b7117799f34c4fe086170a9bdd507974.tar.gz
seden-9c639b97b7117799f34c4fe086170a9bdd507974.tar.bz2
seden-9c639b97b7117799f34c4fe086170a9bdd507974.zip
net-mail/davmail-bin: Bump to version 6.0.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/davmail-bin/Manifest1
-rw-r--r--net-mail/davmail-bin/davmail-bin-5.5.1.ebuild2
-rw-r--r--net-mail/davmail-bin/davmail-bin-6.0.0.ebuild72
3 files changed, 74 insertions, 1 deletions
diff --git a/net-mail/davmail-bin/Manifest b/net-mail/davmail-bin/Manifest
index 229f511..4ad0028 100644
--- a/net-mail/davmail-bin/Manifest
+++ b/net-mail/davmail-bin/Manifest
@@ -1 +1,2 @@
DIST davmail-5.5.1-3299.zip 7043999 SHA256 34dfd350e7142227cdceb267666b5886ce94564b6395fa0e6098d868c110a48e SHA512 e731f6c8af6f019bd7891bd759b0f687f72ff1a7dabaf5e6bb4bb70ebd715820996ecba1d5ad40720438542652be47c15d637b944142924ac00aaecbb4be0746 WHIRLPOOL 957e023def1836b6fbfda957f7cd4b21abd6ba40419b3700789988853ba20dd2018521341dd86e50eb05a01b38e4c96188dc1e3f5802916a96a99bb7294098aa
+DIST davmail-6.0.0-3375.zip 7564456 SHA256 272cd4853fb4adc986318bd859933aa49ccdc1c59f457039a48ae0fbc0977f47 SHA512 9279e94058b8be01a45452cc04d8ae27b493446b7f91b18cc9b295913a1ed1f7c3253d14cf25bc408327816e678ae2c8fecbfcf09c3015267ef9e394b1759d34 WHIRLPOOL 96cfa23294dfde95f6ce970ba30e0e635fbdd1172eb85e1a19666ead71d4ece56e98de6c5f254700fafb63f3206bee19699f2b553553a752fdc4b41e630e62f9
diff --git a/net-mail/davmail-bin/davmail-bin-5.5.1.ebuild b/net-mail/davmail-bin/davmail-bin-5.5.1.ebuild
index 77553f0..703a95e 100644
--- a/net-mail/davmail-bin/davmail-bin-5.5.1.ebuild
+++ b/net-mail/davmail-bin/davmail-bin-5.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
diff --git a/net-mail/davmail-bin/davmail-bin-6.0.0.ebuild b/net-mail/davmail-bin/davmail-bin-6.0.0.ebuild
new file mode 100644
index 0000000..94ab6d0
--- /dev/null
+++ b/net-mail/davmail-bin/davmail-bin-6.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils java-pkg-2
+
+MY_REV="3375"
+MY_PN="davmail"
+MY_P="${MY_PN}-${PV}-${MY_REV}"
+
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.zip"
+DESCRIPTION="POP/IMAP/SMTP/Caldav/Carddav/LDAP Exchange Gateway"
+HOMEPAGE="http://davmail.sourceforge.net/"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="server"
+
+DEPEND="
+ || ( virtual/jre:1.8
+ virtual/jdk:1.8
+ )
+ server? ( acct-user/davmail )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ # libraries
+ java-pkg_dojar lib/*.jar
+ java-pkg_dojar ${MY_PN}.jar
+
+ # icon
+ doicon "${FILESDIR}"/${MY_PN}.png
+
+ # create wrapper script for the client
+ java-pkg_dolauncher ${MY_PN} --main ${MY_PN}.DavGateway --java_args ""
+
+ # desktop entry
+ make_desktop_entry ${MY_PN} "DavMail" /usr/share/pixmaps/${MY_PN}.png "Network"
+
+ if use server ; then
+ # log file
+ touch ${MY_PN}.log
+ insinto /var/log
+ doins ${MY_PN}.log
+ fowners ${MY_PN} /var/log/${MY_PN}.log
+
+ # config files
+ insinto /etc
+ doins "${FILESDIR}"/${MY_PN}.properties
+ newinitd "${FILESDIR}"/${MY_PN}.init ${MY_PN}
+ newconfd "${FILESDIR}"/${MY_PN}.conf ${MY_PN}
+ fi
+}
+
+pkg_postinst() {
+ if use server ; then
+ elog
+ elog "You have chosen to run ${MY_PN} as a system service. You will need to"
+ elog "modify /etc/${MY_PN}.properties to serve your needs."
+ elog
+ elog "You may find it easier to run the ${MY_PN}, configure it via the GUI"
+ elog "and copy the resulting ~/.${MY_PN}.properties to /etc. Make sure you"
+ elog "set ${MY_PN}.server=true and ${MY_PN}.allowRemote=true."
+ elog
+ fi
+}