summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2019-09-25 20:15:51 +0200
committerSven Eden <sven.eden@gmx.de>2019-09-25 20:15:51 +0200
commit370211d632d8ab2fd55f3c74993e2e721e04d584 (patch)
treedf19afce79969b8bd9f137eca2ede8e6ef8cb4bb /media-gfx
parentdev-cpp/pwxlib: Bump to 0.9.0 (diff)
downloadseden-370211d632d8ab2fd55f3c74993e2e721e04d584.tar.gz
seden-370211d632d8ab2fd55f3c74993e2e721e04d584.tar.bz2
seden-370211d632d8ab2fd55f3c74993e2e721e04d584.zip
media-gfx/makeSimplexTexture: Version bump to 0.9.0
Signed-off-by: Sven Eden <sven.eden@gmx.de>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/makeSimplexTexture/Manifest2
-rw-r--r--media-gfx/makeSimplexTexture/makeSimplexTexture-0.9.0.ebuild (renamed from media-gfx/makeSimplexTexture/makeSimplexTexture-0.8.8-r1.ebuild)18
-rw-r--r--media-gfx/makeSimplexTexture/makeSimplexTexture-9999.ebuild18
-rw-r--r--media-gfx/makeSimplexTexture/metadata.xml6
4 files changed, 10 insertions, 34 deletions
diff --git a/media-gfx/makeSimplexTexture/Manifest b/media-gfx/makeSimplexTexture/Manifest
index 77ff318..f445db8 100644
--- a/media-gfx/makeSimplexTexture/Manifest
+++ b/media-gfx/makeSimplexTexture/Manifest
@@ -1 +1 @@
-DIST makeSimplexTexture-0.8.8.tar.gz 30894 SHA256 038c891c3431fb44db0739ea464b2a3061cdd753a67d9bd5f28799c112f05575 SHA512 9de36ef4eb5e708075906f1796e8906724ed9322b6988e59bf55f01afd5a09eb3eeb2cd1bdc52798dd29999da577233b20c684380e76c3fb97b46e1bfe981d1a WHIRLPOOL 63352c9808e87a79023cab3932990084193206cf9d5ab420126c27f6fcba6030c1097c0411c01a5d2c5f0d1aefb8668c999010d68a5852ca6470fe33a600d5ee
+DIST makeSimplexTexture-0.9.0.tar.gz 30922 SHA256 b0b61bfe0c64973d70197366a8a36acc6d4a94e907fea6b75d4653e6cfbfb4e2 SHA512 bfab23b855cdc3aa5df5ce3d82fd52081e4feb2728569424c6f1f1281fc3c077def5126cdbddcc7966fad1bebcd0d5061d2925b5ae73de2e74aa2f50a1d92ea0 WHIRLPOOL c09a7150ec7c390c1a6d4cc9c12e303c89eab7a0dff0f3d14c884a62dadff5e32e95028b5aaae75808fc20c1f85b286f88395429953c327b04c2e9351cb83097
diff --git a/media-gfx/makeSimplexTexture/makeSimplexTexture-0.8.8-r1.ebuild b/media-gfx/makeSimplexTexture/makeSimplexTexture-0.9.0.ebuild
index 7fc17dd..e371425 100644
--- a/media-gfx/makeSimplexTexture/makeSimplexTexture-0.8.8-r1.ebuild
+++ b/media-gfx/makeSimplexTexture/makeSimplexTexture-0.9.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils toolchain-funcs
@@ -12,17 +12,10 @@ SRC_URI="https://github.com/Yamakuzure/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="asan debug lsan tsan"
-
-REQUIRED_USE="
- ?? ( asan lsan tsan )
- asan? ( debug )
- lsan? ( debug )
- tsan? ( debug )
-"
+IUSE="debug"
COMMON_DEPEND="
- >dev-cpp/pwxlib-0.8.9
+ >=dev-cpp/pwxlib-0.9.0
>=media-libs/libsfml-2.5.1
"
DEPEND="${COMMON_DEPEND}"
@@ -35,9 +28,6 @@ src_compile() {
CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
CXX="$(tc-getCXX)" LD="$(tc-getCC)" \
DEBUG="$(usex debug YES NO)" \
- SANITIZE_ADDRESS="$(usex asan YES NO)" \
- SANITIZE_LEAK="$(usex lsan YES NO)" \
- SANITIZE_THREAD="$(usex tsan YES NO)" \
emake || die "emake failed"
}
diff --git a/media-gfx/makeSimplexTexture/makeSimplexTexture-9999.ebuild b/media-gfx/makeSimplexTexture/makeSimplexTexture-9999.ebuild
index fcf0cbf..7f656c4 100644
--- a/media-gfx/makeSimplexTexture/makeSimplexTexture-9999.ebuild
+++ b/media-gfx/makeSimplexTexture/makeSimplexTexture-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils git-r3 toolchain-funcs
@@ -14,17 +14,10 @@ EGIT_SUBMODULES=()
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="asan debug lsan tsan"
-
-REQUIRED_USE="
- ?? ( asan lsan tsan )
- asan? ( debug )
- lsan? ( debug )
- tsan? ( debug )
-"
+IUSE="debug"
COMMON_DEPEND="
- >dev-cpp/pwxlib-0.8.9
+ >=dev-cpp/pwxlib-0.9.0
>=media-libs/libsfml-2.5.1
"
DEPEND="${COMMON_DEPEND}"
@@ -37,9 +30,6 @@ src_compile() {
CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
CXX="$(tc-getCXX)" LD="$(tc-getCC)" \
DEBUG="$(usex debug YES NO)" \
- SANITIZE_ADDRESS="$(usex asan YES NO)" \
- SANITIZE_LEAK="$(usex lsan YES NO)" \
- SANITIZE_THREAD="$(usex tsan YES NO)" \
emake || die "emake failed"
}
diff --git a/media-gfx/makeSimplexTexture/metadata.xml b/media-gfx/makeSimplexTexture/metadata.xml
index af88435..c9f67fc 100644
--- a/media-gfx/makeSimplexTexture/metadata.xml
+++ b/media-gfx/makeSimplexTexture/metadata.xml
@@ -5,11 +5,7 @@
<email>yamakuzure@gmx.net</email>
<name>Sven Eden</name>
</maintainer>
- <use>
- <flag name="asan">Enable address sanitizer</flag>
- <flag name="lsan">Enable leak sanitizer</flag>
- <flag name="tsan">Enable thread sanitizer</flag>
- </use>
+ <use></use>
<upstream>
<remote-id type="github">Yamakuzure/getRandomName</remote-id>
</upstream>