summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/totem/files/totem-2.90.0-smclient-target-detection.patch')
-rw-r--r--media-video/totem/files/totem-2.90.0-smclient-target-detection.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-video/totem/files/totem-2.90.0-smclient-target-detection.patch b/media-video/totem/files/totem-2.90.0-smclient-target-detection.patch
new file mode 100644
index 0000000..ad6cc69
--- /dev/null
+++ b/media-video/totem/files/totem-2.90.0-smclient-target-detection.patch
@@ -0,0 +1,39 @@
+diff -pur totem-2.90.0.orig/configure.in totem-2.90.0/configure.in
+--- totem-2.90.0.orig/configure.in 2010-06-19 14:22:16.000000000 -0400
++++ totem-2.90.0/configure.in 2010-06-25 20:52:05.720211025 -0400
+@@ -153,18 +153,29 @@ GDK_TARGET="$($PKG_CONFIG --variable tar
+ SMCLIENT_PKGS=
+ AC_MSG_CHECKING([which smclient backend to use])
+ AC_ARG_WITH([smclient],
+- [AS_HELP_STRING([--with-smclient],[which smclient backend to use (xsmp/win32/quartz)])],
++ [AS_HELP_STRING([--with-smclient],[which smclient backend to use @<:@xsmp/win32/quartz/auto@:>@])],
+ [],
+- [case "$GDK_TARGET" in
+- x11) with_smclient=xsmp SMCLIENT_PKGS="sm ice" ;;
++ [$with_smclient=auto])
++
++
++if test "$with_smclient" != "no"; then
++
++ if test "$with_smclient" != "auto" -a "$with_smclient" != "yes"; then
++ GDK_TARGET="$with_smclient"
++ fi
++
++ case "$GDK_TARGET" in
++ x11|xsmp) with_smclient=xsmp SMCLIENT_PKGS="sm ice" ;;
+ win32|quartz) with_smclient=$GDK_TARGET ;;
+ *) with_smclient=no ;;
+- esac])
+-AC_MSG_RESULT([$with_smclient])
++ esac
++
++ AC_MSG_RESULT([$with_smclient])
+
+-if test "$with_smclient" != "no"; then
+ PKG_CHECK_MODULES([SMCLIENT],[$SMCLIENT_PKGS])
+ AC_DEFINE([WITH_SMCLIENT],[1],[Define if smclient is enabled])
++else
++ AC_MSG_RESULT([$with_smclient])
+ fi
+
+ AM_CONDITIONAL([WITH_SMCLIENT],[test "$with_smclient" != "no"])