summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2013-03-04 08:41:43 +0100
committerPaul Labedan <plabedan@gmail.com>2013-03-04 08:42:33 +0100
commit722437701712a35eb8e0f5328e24ac0a087f008a (patch)
tree5745135853b4c3969b5f8dc955854a2c253d5d85 /sys-apps
parentcleanup (diff)
downloadplab-722437701712a35eb8e0f5328e24ac0a087f008a.tar.gz
plab-722437701712a35eb8e0f5328e24ac0a087f008a.tar.bz2
plab-722437701712a35eb8e0f5328e24ac0a087f008a.zip
add kmscon
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmscon/Manifest2
-rw-r--r--sys-apps/kmscon/kmscon-6.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/kmscon/Manifest b/sys-apps/kmscon/Manifest
new file mode 100644
index 0000000..f46da59
--- /dev/null
+++ b/sys-apps/kmscon/Manifest
@@ -0,0 +1,2 @@
+DIST kmscon-6.tar.gz 1199199 SHA256 d5fd54e97f078f7abf6bc1bde763cc395f45bc64743ba9652cc80d0afc3f947c SHA512 22fe7d79db4e6169fb797f50294411aee416a6ddd7c96d2401a93f837609da6531ca7c807831eef5777150cd53fb8389f2f0373d5d323d9923b87cf83353d412 WHIRLPOOL 59a549651032655ecb992fb7adf65877a482808e61263314fb9c78da9a2020bab6e369d4fca6c3fb7d9875536a039dc597e87d75f61c0c442b427795d6780e20
+EBUILD kmscon-6.ebuild 1537 SHA256 fc1ee62ffaf1765fc64f74072cad424bdacb5f958b8f74d66f2884ba9bd9c974 SHA512 055fc2cd21b8ddc9ed0bf36d3a84c82e64ccaa7545953ee02ae336e48e2c9250f8676df88dc3ee916d9586c290dd42a0d074c337f2ebf8bc4357cea2fa125948 WHIRLPOOL 89df0df23683d003ffa5787a6fc406fa66d76a03cb0e1c5f115a2bab43ad94d807f072f260d2568e94fe4e5cc1918aa18cae13ba7d1b6ee3ba141e5e620c5054
diff --git a/sys-apps/kmscon/kmscon-6.ebuild b/sys-apps/kmscon/kmscon-6.ebuild
new file mode 100644
index 0000000..7c6d2e9
--- /dev/null
+++ b/sys-apps/kmscon/kmscon-6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils autotools vcs-snapshot
+
+DESCRIPTION="KMS/DRM based virtual Console Emulator"
+HOMEPAGE="https://github.com/dvdhrm/kmscon"
+SRC_URI="http://github.com/dvdhrm/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2.1 BSD-2 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bblit dbus doc +drm +f8x16 +fbdev freetype2 +gles2 +gltex +pango
+static-libs -systemd +udev +xkbcommon +optimizations debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm
+ >=media-libs/mesa-8.0.3[egl,gbm] )
+ freetype2? ( media-libs/freetype:2 )
+ gles2? ( >=media-libs/mesa-8.0.3[gles2] )
+ pango? ( x11-libs/pango )
+ systemd? ( sys-apps/systemd )
+ udev? ( virtual/udev )
+ xkbcommon? ( x11-libs/libxkbcommon )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+ doc? ( dev-util/gtk-doc )"
+
+REQUIRED_USE="drm? ( gles2 )
+ gltex? ( gles2 )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # xkbcommon not in portage
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable systemd) \
+ $(use_enable udev) \
+ $(use_enable dbus) \
+ $(use_enable fbdev) \
+ $(use_enable drm) \
+ $(use_enable gles2) \
+ $(use_enable xkbcommon) \
+ $(use_enable f8x16) \
+ $(use_enable freetype2) \
+ $(use_enable pango) \
+ $(use_enable bblit) \
+ $(use_enable debug) \
+ $(use_enable optimizations) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}