summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2022-08-07 08:03:26 +0200
committerMartin Väth <martin@mvath.de>2022-08-07 08:04:44 +0200
commit02e56924c9e01ae6b08ab1f3a30bf18781f0fb23 (patch)
tree1f0c8cc93f38b233726a29c3980a59c3eba53489 /media-video
parentMake pkgcheck happy (diff)
downloadmv-02e56924c9e01ae6b08ab1f3a30bf18781f0fb23.tar.gz
mv-02e56924c9e01ae6b08ab1f3a30bf18781f0fb23.tar.bz2
mv-02e56924c9e01ae6b08ab1f3a30bf18781f0fb23.zip
Fix docinto, http->https, remove unneeded packages
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avidemux/avidemux-2.7.8.ebuild48
-rw-r--r--media-video/avidemux/metadata.xml5
-rw-r--r--media-video/avinfo/metadata.xml2
-rw-r--r--media-video/pipewire/Manifest1
-rw-r--r--media-video/pipewire/files/99-pipewire-default-hook.conf17
-rw-r--r--media-video/pipewire/files/gentoo-pipewire-launcher.in29
-rw-r--r--media-video/pipewire/files/pipewire-0.3.25-enable-failed-mlock-warning.patch12
-rw-r--r--media-video/pipewire/files/pipewire.desktop-r112
-rw-r--r--media-video/pipewire/metadata.xml35
-rw-r--r--media-video/pipewire/pipewire-0.3.53.ebuild365
-rw-r--r--media-video/video-mv/metadata.xml2
11 files changed, 29 insertions, 499 deletions
diff --git a/media-video/avidemux/avidemux-2.7.8.ebuild b/media-video/avidemux/avidemux-2.7.8.ebuild
index 8b371ad5..55a53cdd 100644
--- a/media-video/avidemux/avidemux-2.7.8.ebuild
+++ b/media-video/avidemux/avidemux-2.7.8.ebuild
@@ -1,27 +1,31 @@
-# Copyright 1999-2022 Gentoo Authors and Martin V\"ath
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
+
inherit cmake desktop flag-o-matic qmake-utils xdg
DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
HOMEPAGE="http://fixounet.free.fr/avidemux"
-SRC_URI="https://github.com/mean00/avidemux2/archive/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/mean00/avidemux2_i18n/archive/${PV}.tar.gz -> ${PN}-i18n-${PV}.tar.gz"
+SRC_URI="
+ https://github.com/mean00/avidemux2/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/mean00/avidemux2_i18n/archive/${PV}.tar.gz -> ${PN}-i18n-${PV}.tar.gz
+"
# Multiple licenses because of all the bundled stuff.
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
SLOT="2.7"
KEYWORDS="~amd64 ~x86"
-IUSE="debug nls nvenc opengl qt5 sdl vaapi vdpau xv"
+IUSE="debug nls opengl qt5 sdl vaapi vdpau xv"
-BDEPEND="dev-lang/yasm
- qt5? ( dev-qt/linguist-tools:5 )"
+BDEPEND="
+ dev-lang/yasm
+ qt5? ( dev-qt/linguist-tools:5 )
+"
DEPEND="
- ~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,xv?,nvenc?]
- nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) )
+ ~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,xv?]
opengl? ( virtual/opengl:0 )
qt5? (
dev-qt/qtcore:5
@@ -32,20 +36,24 @@ DEPEND="
)
vaapi? ( x11-libs/libva:0= )
"
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
nls? ( virtual/libintl:0 )
!<media-video/avidemux-${PV}
"
+
PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt5?]"
S="${WORKDIR}/avidemux2-${PV}"
src_unpack() {
default
- mv -f -T avidemux2_i18n-${PV} "${S}"/avidemux/qt4/i18n >/dev/null || die
+ mv -f -T avidemux2_i18n-"${PV}" "${S}"/avidemux/qt4/i18n >/dev/null || die
}
src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.7.4-qt-5.15.patch"
+
processes="buildCli:avidemux/cli"
use qt5 && processes+=" buildQt4:avidemux/qt4"
@@ -55,25 +63,21 @@ src_prepare() {
if use qt5; then
# Fix icon name -> avidemux-2.7
- sed -i -e "/^Icon/ s:${PN}\.png:${PN}-${SLOT}:" appImage/${PN}.desktop || \
- die "Icon name fix failed."
+ sed -i -e "/^Icon/ s:${PN}\.png:${PN}-${SLOT}:" appImage/"${PN}".desktop || die "Icon name fix failed."
# The desktop file is broken. It uses avidemux3_portable instead of avidemux3_qt5
- sed -i -re '/^Exec/ s:(avidemux3_)portable:\1qt5:' appImage/${PN}.desktop || \
- die "Desktop file fix failed."
+ sed -i -re '/^Exec/ s:(avidemux3_)portable:\1qt5:' appImage/"${PN}".desktop || die "Desktop file fix failed."
# QA warnings: missing trailing ';' and 'Application' is deprecated.
- sed -i -e 's/Application;AudioVideo/AudioVideo;/g' appImage/${PN}.desktop || \
- die "Desktop file fix failed."
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' appImage/"${PN}".desktop || die "Desktop file fix failed."
# Now rename the desktop file to not collide with 2.6.
- mv appImage/${PN}.desktop ${PN}-${SLOT}.desktop || die "Collision rename failed."
+ mv appImage/"${PN}".desktop "${PN}-${SLOT}".desktop || die "Collision rename failed."
fi
# Remove "Build Option" dialog because it doesn't reflect
# what the GUI can or has been built with. (Bug #463628)
- sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || \
- die "Couldn't remove \"Build Option\" dialog."
+ sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || die "Couldn't remove \"Build Option\" dialog."
# Fix underlinking with gold
sed -i -e 's/{QT_QTGUI_LIBRARY}/{QT_QTGUI_LIBRARY} -lXext/' \
@@ -132,7 +136,7 @@ src_install() {
if use qt5; then
cd "${S}" || die "Can't enter source folder"
- newicon ${PN}_icon.png ${PN}-${SLOT}.png
- domenu ${PN}-${SLOT}.desktop
+ newicon "${PN}"_icon.png "${PN}-${SLOT}".png
+ domenu "${PN}-${SLOT}".desktop
fi
}
diff --git a/media-video/avidemux/metadata.xml b/media-video/avidemux/metadata.xml
index ad0bd2cc..3d2492c5 100644
--- a/media-video/avidemux/metadata.xml
+++ b/media-video/avidemux/metadata.xml
@@ -1,13 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>media-video@gentoo.org</email>
<name>Gentoo Video project</name>
</maintainer>
- <use>
- <flag name="nvenc">Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.</flag>
- </use>
<upstream>
<remote-id type="sourceforge">avidemux</remote-id>
</upstream>
diff --git a/media-video/avinfo/metadata.xml b/media-video/avinfo/metadata.xml
index b919c846..9474792a 100644
--- a/media-video/avinfo/metadata.xml
+++ b/media-video/avinfo/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>martin@mvath.de</email>
diff --git a/media-video/pipewire/Manifest b/media-video/pipewire/Manifest
deleted file mode 100644
index 6d6aa765..00000000
--- a/media-video/pipewire/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pipewire-0.3.53.tar.gz 1783505 BLAKE2B 269466c6ba78cb85516dc714f3aa5d71cdf72a859b6e1a11c60062da6dcd56eefc78958fe026b9fd11d61fd6fbe6f2aac54a2a9fd77d4ee474687f5d54628c38 SHA512 50f23a7b71f3eb20657ff75de54a9f3056270bf05a5472ec9c7dea1c9d0ed391b6b09496d58b065c3cbc40f9be8088b6737cbf0731973498bcd5a8176c42d443
diff --git a/media-video/pipewire/files/99-pipewire-default-hook.conf b/media-video/pipewire/files/99-pipewire-default-hook.conf
deleted file mode 100644
index 7145acce..00000000
--- a/media-video/pipewire/files/99-pipewire-default-hook.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-# Load pipewire configuration at conf hook processing time. This allows to
-# override pulseaudio defaults configuration which is also applied via hook.
-#
-# Note since hooks are run after @GENTOO_PORTAGE_EPREFIX@/etc/asound.conf and ~/.asoundrc are applied,
-# we load these again here make sure that user configuration takes precedence.
-
-@hooks [
- {
- func load
- files [
- "@GENTOO_PORTAGE_EPREFIX@/usr/share/alsa/alsa.conf.d/99-pipewire-default.conf"
- "@GENTOO_PORTAGE_EPREFIX@/etc/asound.conf"
- "~/.asoundrc"
- ]
- errors false
- }
-]
diff --git a/media-video/pipewire/files/gentoo-pipewire-launcher.in b/media-video/pipewire/files/gentoo-pipewire-launcher.in
deleted file mode 100644
index 495c47f6..00000000
--- a/media-video/pipewire/files/gentoo-pipewire-launcher.in
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-# PipeWire launcher script for XDG compliant desktops on OpenRC.
-#
-# systemd users are very _STRONGLY_ advised to use the much
-# more reliable and predictable user units instead.
-
-# WARNING: This script assumes being run inside XDG compliant session,
-# which means D-Bus session instance is expected to be correctly set up
-# prior to this script starting. If that is not true, things may break!
-
-# Best to reap any existing daemons and only then try to start a new set.
-pkill -u "${USER}" -x pipewire\|wireplumber 1>/dev/null 2>&1
-
-# The core daemon which by itself does probably nothing.
-@GENTOO_PORTAGE_EPREFIX@/usr/bin/pipewire &
-
-# The so called pipewire-pulse daemon used for PulseAudio compatibility.
-# Commenting this out will stop the PA proxying daemon from starting,
-# however ALSA (with pipewire-alsa), JACK (with jack-sdk) and PW API using
-# clients will still have access to audio and may end up clashing with
-# non-PW apps over HW control (most notably, /usr/bin/pulseaudio daemon).
-@GENTOO_PORTAGE_EPREFIX@/usr/bin/pipewire -c pipewire-pulse.conf &
-
-# Hack for bug #822498
-sleep 1
-
-# Finally a session manager is required for PipeWire to do anything.
-exec @GENTOO_PORTAGE_EPREFIX@/usr/bin/wireplumber
diff --git a/media-video/pipewire/files/pipewire-0.3.25-enable-failed-mlock-warning.patch b/media-video/pipewire/files/pipewire-0.3.25-enable-failed-mlock-warning.patch
deleted file mode 100644
index bdb43fe5..00000000
--- a/media-video/pipewire/files/pipewire-0.3.25-enable-failed-mlock-warning.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/daemon/pipewire.conf.in b/src/daemon/pipewire.conf.in
---- a/src/daemon/pipewire.conf.in
-+++ b/src/daemon/pipewire.conf.in
-@@ -6,7 +6,7 @@ context.properties = {
- #support.dbus = true
- #link.max-buffers = 64
- link.max-buffers = 16 # version < 3 clients can't handle more
-- #mem.warn-mlock = false
-+ mem.warn-mlock = true # Gentoo should have good RLIMITs now
- #mem.allow-mlock = true
- #mem.mlock-all = false
- #clock.power-of-two-quantum = true
diff --git a/media-video/pipewire/files/pipewire.desktop-r1 b/media-video/pipewire/files/pipewire.desktop-r1
deleted file mode 100644
index d9503129..00000000
--- a/media-video/pipewire/files/pipewire.desktop-r1
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name[de]=PipeWire Mediensystem
-Name=PipeWire Media System
-Comment[de]=Das PipeWire Mediensystem starten
-Comment=Start the PipeWire Media System
-Exec=/usr/bin/gentoo-pipewire-launcher
-Terminal=false
-Type=Application
-X-GNOME-HiddenUnderSystemd=true
-X-KDE-HiddenUnderSystemd=true
-X-systemd-skip=true
diff --git a/media-video/pipewire/metadata.xml b/media-video/pipewire/metadata.xml
deleted file mode 100644
index 1153e0e4..00000000
--- a/media-video/pipewire/metadata.xml
+++ /dev/null
@@ -1,35 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <maintainer type="person">
- <email>sam@gentoo.org</email>
- <name>Sam James</name>
- </maintainer>
- <maintainer type="person">
- <email>asturm@gentoo.org</email>
- <name>Andreas Sturmlechner</name>
- </maintainer>
- <maintainer type="person">
- <email>whissi@gentoo.org</email>
- <name>Thomas Deutschmann</name>
- </maintainer>
- <upstream>
- <bugs-to>https://gitlab.freedesktop.org/pipewire/pipewire/-/issues</bugs-to>
- <changelog>https://gitlab.freedesktop.org/pipewire/pipewire/-/releases</changelog>
- <doc>https://gitlab.freedesktop.org/pipewire/pipewire/-/wikis/home</doc>
- </upstream>
- <use>
- <flag name="echo-cancel">Enable WebRTC-based echo canceller via <pkg>media-libs/webrtc-audio-processing</pkg></flag>
- <flag name="extra">Build pw-cat/pw-play/pw-record</flag>
- <flag name="jack-client">Install a plugin for running PipeWire as a JACK client</flag>
- <flag name="jack-sdk">Use PipeWire as JACK replacement</flag>
- <flag name="lv2">Allow loading LV2 plugins via <pkg>media-libs/lv2</pkg></flag>
- <flag name="pipewire-alsa">Replace PulseAudio's ALSA plugin with PipeWire's plugin</flag>
- <flag name="ssl">Enable raop-sink support (needs <pkg>dev-libs/openssl</pkg>)</flag>
- <flag name="system-service">Install systemd unit files for running as a system service. Not recommended.</flag>
- </use>
-</pkgmetadata>
diff --git a/media-video/pipewire/pipewire-0.3.53.ebuild b/media-video/pipewire/pipewire-0.3.53.ebuild
deleted file mode 100644
index 76dc5436..00000000
--- a/media-video/pipewire/pipewire-0.3.53.ebuild
+++ /dev/null
@@ -1,365 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit flag-o-matic meson-multilib optfeature prefix python-any-r1 systemd udev
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
- inherit git-r3
-else
- if [[ ${PV} == *_p* ]] ; then
- MY_COMMIT=""
- SRC_URI="https://gitlab.freedesktop.org/pipewire/pipewire/-/archive/${MY_COMMIT}/pipewire-${MY_COMMIT}.tar.bz2 -> ${P}.tar.bz2"
- S="${WORKDIR}"/${PN}-${MY_COMMIT}
- else
- SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
- fi
-
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-DESCRIPTION="Multimedia processing graphs"
-HOMEPAGE="https://pipewire.org/"
-
-LICENSE="MIT LGPL-2.1+ GPL-2"
-# ABI was broken in 0.3.42 for https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/49
-SLOT="0/0.4"
-IUSE="alsa bluetooth doc echo-cancel extra gstreamer jack-client jack-sdk lv2 pipewire-alsa ssl system-service systemd test udev v4l X zeroconf"
-
-# Once replacing system JACK libraries is possible, it's likely that
-# jack-client IUSE will need blocking to avoid users accidentally
-# configuring their systems to send PW sink output to the emulated
-# JACK's sink - doing so is likely to yield no audio, cause a CPU
-# cycles consuming loop (and may even cause GUI crashes)!
-
-REQUIRED_USE="
- jack-sdk? ( !jack-client )
- system-service? ( systemd )
-"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-util/meson-0.59
- virtual/pkgconfig
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
-"
-RDEPEND="
- acct-group/audio
- media-libs/alsa-lib
- sys-apps/dbus[${MULTILIB_USEDEP}]
- sys-libs/readline:=
- sys-libs/ncurses:=[unicode(+)]
- virtual/libintl[${MULTILIB_USEDEP}]
- bluetooth? (
- media-libs/fdk-aac
- media-libs/libldac
- media-libs/libfreeaptx
- media-libs/sbc
- >=net-wireless/bluez-4.101:=
- virtual/libusb:1
- )
- echo-cancel? ( media-libs/webrtc-audio-processing:0 )
- extra? (
- >=media-libs/libsndfile-1.0.20
- )
- gstreamer? (
- >=dev-libs/glib-2.32.0:2
- >=media-libs/gstreamer-1.10.0:1.0
- media-libs/gst-plugins-base:1.0
- )
- jack-client? ( >=media-sound/jack2-1.9.10:2[dbus] )
- jack-sdk? (
- !media-sound/jack-audio-connection-kit
- !media-sound/jack2
- )
- lv2? ( media-libs/lilv )
- pipewire-alsa? (
- >=media-libs/alsa-lib-1.1.7[${MULTILIB_USEDEP}]
- )
- !pipewire-alsa? ( alsa? ( media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio] ) )
- ssl? ( dev-libs/openssl:= )
- systemd? ( sys-apps/systemd )
- system-service? (
- acct-user/pipewire
- acct-group/pipewire
- )
- udev? ( virtual/libudev[${MULTILIB_USEDEP}] )
- v4l? ( media-libs/libv4l )
- X? (
- media-libs/libcanberra
- x11-libs/libX11
- x11-libs/libXfixes
- )
- zeroconf? ( net-dns/avahi )
-"
-
-DEPEND="${RDEPEND}"
-
-# TODO: Consider use cases where pipewire is not used for driving audio
-# Doing so with WirePlumber currently involves editing Lua scripts
-PDEPEND=">=media-video/wireplumber-0.4.8-r3"
-
-# Present RDEPEND that are currently always disabled due to the PW
-# code using them being required to be disabled by Gentoo guidelines
-# (i.e. developer binaries not meant for users) and unready code
-# media-video/ffmpeg:=
-# media-libs/libsdl2
-# >=media-libs/vulkan-loader-1.1.69
-#
-# Ditto for DEPEND
-# >=dev-util/vulkan-headers-1.1.69
-
-DOCS=( {README,INSTALL}.md NEWS )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.3.25-enable-failed-mlock-warning.patch
-)
-
-# limitsdfile related code taken from =sys-auth/realtime-base-0.1
-# with changes as necessary.
-limitsdfile=40-${PN}.conf
-
-python_check_deps() {
- has_version -b "dev-python/docutils[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
- default
-
- einfo "Generating ${limitsdfile}"
- cat > ${limitsdfile} <<- EOF || die
- # Start of ${limitsdfile} from ${P}
-
- @audio - memlock 256
-
- $(use system-service && {
- echo @pipewire - rtprio 95
- echo @pipewire - priority -19
- echo @pipewire - memlock 4194304
- })
-
- # End of ${limitsdfile} from ${P}
- EOF
-}
-
-multilib_src_configure() {
- # https://bugs.gentoo.org/838301
- filter-flags -fno-semantic-interposition
-
- local emesonargs=(
- -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
-
- $(meson_native_use_feature zeroconf avahi)
- $(meson_native_use_feature doc docs)
- $(meson_native_enabled examples) # TODO: Figure out if this is still important now that media-session gone
- $(meson_native_enabled man)
- $(meson_feature test tests)
- -Dinstalled_tests=disabled # Matches upstream; Gentoo never installs tests
- $(meson_native_use_feature gstreamer)
- $(meson_native_use_feature gstreamer gstreamer-device-provider)
- $(meson_native_use_feature systemd)
-
- $(meson_native_use_feature system-service systemd-system-service)
- -Dsystemd-system-unit-dir="$(systemd_get_systemunitdir)"
- -Dsystemd-user-unit-dir="$(systemd_get_userunitdir)"
-
- $(meson_native_use_feature systemd systemd-user-service)
- $(meson_feature pipewire-alsa) # Allows integrating ALSA apps into PW graph
- -Dspa-plugins=enabled
- -Dalsa=enabled # Allows using kernel ALSA for sound I/O (NOTE: media-session is gone so IUSE=alsa/spa_alsa/alsa-backend might be possible)
- -Daudiomixer=enabled # Matches upstream
- -Daudioconvert=enabled # Matches upstream
- $(meson_native_use_feature bluetooth bluez5)
- $(meson_native_use_feature bluetooth bluez5-backend-hsp-native)
- $(meson_native_use_feature bluetooth bluez5-backend-hfp-native)
- $(meson_native_use_feature bluetooth bluez5-backend-ofono)
- $(meson_native_use_feature bluetooth bluez5-backend-hsphfpd)
- $(meson_native_use_feature bluetooth bluez5-codec-aac)
- $(meson_native_use_feature bluetooth bluez5-codec-aptx)
- $(meson_native_use_feature bluetooth bluez5-codec-ldac)
- $(meson_native_use_feature bluetooth libusb) # At least for now only used by bluez5 native (quirk detection of adapters)
- $(meson_native_use_feature echo-cancel echo-cancel-webrtc) #807889
- # Not yet packaged.
- -Dbluez5-codec-lc3plus=disabled
- -Dcontrol=enabled # Matches upstream
- -Daudiotestsrc=enabled # Matches upstream
- -Dffmpeg=disabled # Disabled by upstream and no major developments to spa/plugins/ffmpeg/ since May 2020
- -Dpipewire-jack=enabled # Allows integrating JACK apps into PW graph
- $(meson_native_use_feature jack-client jack) # Allows PW to act as a JACK client
- $(meson_use jack-sdk jack-devel)
- $(usex jack-sdk "-Dlibjack-path=${EPREFIX}/usr/$(get_libdir)" '')
- -Dsupport=enabled # Miscellaneous/common plugins, such as null sink
- -Devl=disabled # Matches upstream
- -Dtest=disabled # fakesink and fakesource plugins
- $(meson_native_use_feature lv2)
- $(meson_native_use_feature v4l v4l2)
- -Dlibcamera=disabled # libcamera is not in Portage tree
- $(meson_native_use_feature ssl raop)
- -Dvideoconvert=enabled # Matches upstream
- -Dvideotestsrc=enabled # Matches upstream
- -Dvolume=enabled # Matches upstream
- -Dvulkan=disabled # Uses pre-compiled Vulkan compute shader to provide a CGI video source (dev thing; disabled by upstream)
- $(meson_native_use_feature extra pw-cat)
- $(meson_feature udev)
- -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
- -Dsdl2=disabled # Controls SDL2 dependent code (currently only examples when -Dinstalled_tests=enabled which we never install)
- $(meson_native_use_feature extra sndfile) # Enables libsndfile dependent code (currently only pw-cat)
- -Dsession-managers="[]" # All available session managers are now their own projects, so there's nothing to build
-
- # Just for bell sounds in X11 right now.
- $(meson_native_use_feature X x11)
- $(meson_native_use_feature X x11-xfixes)
- $(meson_native_use_feature X libcanberra)
- )
-
- meson_src_configure
-}
-
-multilib_src_install() {
- # Our custom DOCS do not exist in multilib source directory
- DOCS= meson_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- insinto /etc/security/limits.d
- doins ${limitsdfile}
-
- if use pipewire-alsa; then
- dodir /etc/alsa/conf.d
-
- # Install pipewire conf loader hook
- insinto /usr/share/alsa/alsa.conf.d
- doins "${FILESDIR}"/99-pipewire-default-hook.conf
- eprefixify "${ED}"/usr/share/alsa/alsa.conf.d/99-pipewire-default-hook.conf
-
- # These will break if someone has /etc that is a symbolic link to a subfolder! See #724222
- # And the current dosym8 -r implementation is likely affected by the same issue, too.
- dosym ../../../usr/share/alsa/alsa.conf.d/50-pipewire.conf /etc/alsa/conf.d/50-pipewire.conf
- dosym ../../../usr/share/alsa/alsa.conf.d/99-pipewire-default-hook.conf /etc/alsa/conf.d/99-pipewire-default-hook.conf
- fi
-
- if ! use systemd; then
- insinto /etc/xdg/autostart
- newins "${FILESDIR}"/pipewire.desktop-r1 pipewire.desktop
-
- exeinto /usr/bin
- newexe "${FILESDIR}"/gentoo-pipewire-launcher.in gentoo-pipewire-launcher
- eprefixify "${ED}"/usr/bin/gentoo-pipewire-launcher
- fi
-}
-
-pkg_postinst() {
- use udev && udev_reload
-
- elog "It is recommended to raise RLIMIT_MEMLOCK to 256 for users"
- elog "using PipeWire. Do it either manually or add yourself"
- elog "to the 'audio' group:"
- elog
- elog " usermod -aG audio <youruser>"
- elog
-
- if ! use jack-sdk; then
- elog "JACK emulation is incomplete and not all programs will work. PipeWire's"
- elog "alternative libraries have been installed to a non-default location."
- elog "To use them, put pw-jack <application> before every JACK application."
- elog "When using pw-jack, do not run jackd/jackdbus. However, a virtual/jack"
- elog "provider is still needed to compile the JACK applications themselves."
- elog
- fi
-
- if use systemd; then
- elog "When switching from PulseAudio, you may need to disable PulseAudio:"
- elog
- elog " systemctl --user disable pulseaudio.service pulseaudio.socket"
- elog
- elog "To use PipeWire, the user units must be manually enabled"
- elog "by running this command as each user you use for desktop activities:"
- elog
- elog " systemctl --user enable pipewire.socket pipewire-pulse.socket"
- elog
- elog "A reboot is recommended to avoid interferences from still running"
- elog "PulseAudio daemon."
- elog
- elog "Both new users and those upgrading need to enable WirePlumber"
- elog "for relevant users:"
- elog
- elog " systemctl --user disable pipewire-media-session.service"
- elog " systemctl --user --force enable wireplumber.service"
- elog
- elog "Root user may replace --user with --global to change system default"
- elog "configuration for all of the above commands."
- else
- ewarn "PipeWire daemon startup has been moved to a launcher script!"
- ewarn "Make sure that ${EROOT}/etc/pipewire/pipewire.conf either does not exist or no"
- ewarn "longer is set to start a session manager or PulseAudio compatibility daemon (all"
- ewarn "lines similar to '{ path = /usr/bin/pipewire*' should be commented out)"
- ewarn
- ewarn "Those manually starting /usr/bin/pipewire via .xinitrc or similar _must_ from"
- ewarn "now on start ${EROOT}/usr/bin/gentoo-pipewire-launcher instead! It is highly"
- ewarn "advised that a D-Bus user session is set up before starting the script."
- ewarn
- if has_version 'media-sound/pulseaudio[daemon]' || has_version 'media-sound/pulseaudio-daemon'; then
- elog "This ebuild auto-enables PulseAudio replacement. Because of that, users"
- elog "are recommended to edit pulseaudio client configuration files:"
- elog "${EROOT}/etc/pulse/client.conf and ${EROOT}/etc/pulse/client.conf.d/enable-autospawn.conf"
- elog "if it exists, and disable autospawning of the original daemon by setting:"
- elog
- elog " autospawn = no"
- elog
- elog "Please note that the semicolon (;) must _NOT_ be at the beginning of the line!"
- elog
- elog "Alternatively, if replacing PulseAudio daemon is not desired, edit"
- elog "${EROOT}/usr/bin/gentoo-pipewire-launcher by commenting out the relevant"
- elog "command:"
- elog
- elog "#${EROOT}/usr/bin/pipewire -c pipewire-pulse.conf &"
- elog
- fi
- elog "NOTE:"
- elog "Starting with PipeWire-0.3.30, this package is no longer installing its config"
- elog "into ${EROOT}/etc/pipewire by default. In case you need to change"
- elog "its config, please start by copying default config from ${EROOT}/usr/share/pipewire"
- elog "and just override the sections you want to change."
- fi
- elog
-
- elog "For latest tips and tricks, troubleshooting information and documentation"
- elog "in general, please refer to https://wiki.gentoo.org/wiki/PipeWire"
- elog
-
- optfeature_header "The following can be installed for optional runtime features:"
- optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
-
- if has_version 'net-misc/ofono' ; then
- ewarn "Native backend has become default. Please disable oFono via:"
- if systemd_is_booted ; then
- ewarn "systemctl disable ofono"
- else
- ewarn "rc-update delete ofono"
- fi
- ewarn
- fi
-
- if use system-service; then
- ewarn
- ewarn "WARNING: you have enabled the system-service USE flag, which installs"
- ewarn "the system-wide systemd units that enable PipeWire to run as a system"
- ewarn "service. This is more than likely NOT what you want. You are strongly"
- ewarn "advised not to enable this mode and instead stick with systemd user"
- ewarn "units. The default configuration files will likely not work out of"
- ewarn "box, and you are on your own with configuration."
- ewarn
- fi
-}
diff --git a/media-video/video-mv/metadata.xml b/media-video/video-mv/metadata.xml
index ab10fb7d..99cc13a4 100644
--- a/media-video/video-mv/metadata.xml
+++ b/media-video/video-mv/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>martin@mvath.de</email>