summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <lukas.elsner@freifalt.com>2011-06-16 16:40:14 +0200
committerLukas Elsner <lukas.elsner@freifalt.com>2011-06-16 16:40:14 +0200
commit78fe5680cdce3a24b449dc5557e5c9dfaafe203f (patch)
tree344df1eac6e8d28035e2796b3a10741e6c72919e /app-misc
parentupdate to sparkleshare 0.2.2 (diff)
downloadluman-78fe5680cdce3a24b449dc5557e5c9dfaafe203f.tar.gz
luman-78fe5680cdce3a24b449dc5557e5c9dfaafe203f.tar.bz2
luman-78fe5680cdce3a24b449dc5557e5c9dfaafe203f.zip
added missing file
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/sparkleshare/sparkleshare-0.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/sparkleshare/sparkleshare-0.2.2.ebuild b/app-misc/sparkleshare/sparkleshare-0.2.2.ebuild
new file mode 100644
index 0000000..c39c76c
--- /dev/null
+++ b/app-misc/sparkleshare/sparkleshare-0.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.1.ebuild,v 1.3 2010/07/12 20:28:24 fauli Exp $
+
+EAPI=3
+
+inherit base mono
+
+MY_PV="${PV/_beta/-beta}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SparkleShare is a file sharing and collaboration tool inspired by
+Dropbox"
+HOMEPAGE="http://www.sparkleshare.org"
+#SRC_URI="http://www.sparkleshare.org/${MY_P}.tar.gz"
+SRC_URI="https://github.com/downloads/hbons/SparkleShare/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2.2
+ >=dev-util/monodevelop-2.0
+ >=dev-dotnet/gtk-sharp-2.12.7
+ >=dev-dotnet/webkit-sharp-0.3"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.7
+ net-misc/openssh
+ >=gnome-base/gvfs-1.3
+ dev-util/intltool"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README COPYING
+}
+