aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2023-05-13 14:30:19 +0100
committerPaul Healy <lmiphay@gmail.com>2023-05-13 14:30:19 +0100
commitf77b639e543c4dba688f9bc45d8c0cc25fa997b5 (patch)
treee4f83f5f8398a2e35d0f1fd4a627fc7dbf61bf54 /media-video
parentadd py11 (diff)
downloadlmiphay-f77b639e543c4dba688f9bc45d8c0cc25fa997b5.tar.gz
lmiphay-f77b639e543c4dba688f9bc45d8c0cc25fa997b5.tar.bz2
lmiphay-f77b639e543c4dba688f9bc45d8c0cc25fa997b5.zip
revbump streamdeck-ui
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/streamdeck-ui/Manifest2
-rw-r--r--media-video/streamdeck-ui/streamdeck-ui-2.0.15.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/media-video/streamdeck-ui/Manifest b/media-video/streamdeck-ui/Manifest
index aca4c24..75c0e83 100644
--- a/media-video/streamdeck-ui/Manifest
+++ b/media-video/streamdeck-ui/Manifest
@@ -1,2 +1,4 @@
+DIST streamdeck-ui-2.0.15.tar.gz 3919827 BLAKE2B 63bad0042d648ece2dad2946ec475e0875946082a128359331a878dbf52c5b4a15dfb701b074d8b570c4b42b607432ed2165dd145dce04ae777bc3147705b4c4 SHA512 5f931a968c68b88a38fc44c3d2310fa73cb9a01c67f289dea39214e6176aad9b004ad6c87f63da41cccfa9f7f60f2f6022e4376ebe2a4cac7721cf9b55b079e0
DIST streamdeck-ui-2.0.4.tar.gz 3896954 BLAKE2B ea0f68675da72c032036ad13584d60cbdd7dd61ea4c7cdd939b2345c7a62b0e3f70d9197dd33216dcda78a9bbfae36de6cf6215300b477e09b2ae03573bbf8d0 SHA512 404cfe789c702f1087d652151b5f7b2234c255a84cf5bee6b6a7935e4cd18da002bc1a4fd3177e6a7d036870e055cfc6c1d7bdba7766991dd518800904afbf63
+EBUILD streamdeck-ui-2.0.15.ebuild 1389 BLAKE2B 1f7ab7e710413b3a2c58b9f238c5a014a82d513106c4d29b27821986ef4dadf13b5696cc1584e6d8cb4aeb5bd27129639b0984f02ebb26e8fea76a444ff55713 SHA512 efc7639c05e5c2ff80ca07a364b6a7c99fa9cd80edac028d74369264e88bfe887eca9b6db0760f95a6973965aa2dbe1a30887438fefedb060a5a0fa3d64346cc
EBUILD streamdeck-ui-2.0.4.ebuild 1389 BLAKE2B 4d3c0053e0070eda1817887031102c9614361024363f452f6e48e6fa3bbdc4400dff5398253d5038765daed541fe7f1212de21ceb70f3fb67b53ce1ad068ccb5 SHA512 90647356c3ceaf8df62987d03f60840bb3d1c9abaea192fbb6a381188484ed4b708b4ce308fbbf5c20bd0308c7662254b0024a2c1fde89e15055eb10b52a3f77
diff --git a/media-video/streamdeck-ui/streamdeck-ui-2.0.15.ebuild b/media-video/streamdeck-ui/streamdeck-ui-2.0.15.ebuild
new file mode 100644
index 0000000..9192d0e
--- /dev/null
+++ b/media-video/streamdeck-ui/streamdeck-ui-2.0.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=poetry
+#DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="A Linux compatible UI for the Elgato Stream Deck"
+HOMEPAGE="https://github.com/timothycrosley/streamdeck-ui"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/timothycrosley/streamdeck-ui.git"
+else
+ SRC_URI="https://github.com/timothycrosley/streamdeck-ui/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ #S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/hidapi
+ dev-python/filetype[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pynput[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP},designer]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+ media-libs/elgato-streamdeck[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i "s#os.path.dirname(os.path.abspath(__file__))#'/usr/share/streamdeck-ui'#" streamdeck_ui/config.py
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ insinto /usr/share/streamdeck-ui
+ doins streamdeck_ui/logo.png
+ doins -r streamdeck_ui/fonts
+ distutils-r1_src_install
+}