aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2016-05-23 19:00:05 +0100
committerPaul Healy <lmiphay@gmail.com>2016-05-23 19:00:05 +0100
commit7bc3a11227623a6ae73ebf49adb2505abd8c57e1 (patch)
tree92bae212848e9ce8542d123ce6353e55c2f51264 /dev-db
parentrev bump to latest (diff)
downloadlmiphay-7bc3a11227623a6ae73ebf49adb2505abd8c57e1.tar.gz
lmiphay-7bc3a11227623a6ae73ebf49adb2505abd8c57e1.tar.bz2
lmiphay-7bc3a11227623a6ae73ebf49adb2505abd8c57e1.zip
add ebuild for influxdb bin dist
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/influxdb/Manifest4
-rw-r--r--dev-db/influxdb/files/influxdb.conf.d3
-rw-r--r--dev-db/influxdb/files/influxdb.init.d30
-rw-r--r--dev-db/influxdb/influxdb-0.13.0.ebuild38
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-db/influxdb/Manifest b/dev-db/influxdb/Manifest
new file mode 100644
index 0000000..43c412e
--- /dev/null
+++ b/dev-db/influxdb/Manifest
@@ -0,0 +1,4 @@
+AUX influxdb.conf.d 80 SHA256 dc6ea4c5b7f164e0e251ca3d3bce7079b62c316d45bc7d3b433d27a97c664ecb SHA512 61fbdc773b3644e66daa06ed27f30015a9df683dcc873c4c5c45c9c7d19aef8f52ac41801fe9c88daa84f79a3b7f3e0fdda0ce7d333269529c7ac410acd37859 WHIRLPOOL cc0eda9926ddcd71a31df3ef3e11c65a8e8ca4ae8d10beb741bd22d11a68270175f80cd619357500107be1bea9dff7580f815b3e5c5be3920c269128cd694409
+AUX influxdb.init.d 698 SHA256 49e9b08d4a70aa3e469ba45465fcd23f7b14d7ed7941526d57cfd1aa841b787c SHA512 b8d3b7557b47191bc3b49eafbe6480cdbafceb76a277404a1d50fc77e8e5a18e019487ad5dfcafa514ccd601f2a200fce5836fa95e5f17f208fc6ecb4d9a56f8 WHIRLPOOL 6ee54d6d9989544f25cdc1475e4608d4e67caab0f9b5543d71da6ab23df8d7ad25927c3a58e7eac12580839a1493f3969a419adf3040b5b64dd2531887d582e4
+DIST influxdb_0.13.0_amd64.deb 18143284 SHA256 18b9be8173b770f2c80d8a8c415535c2d2f66cec5e6a5d522415a18875422680 SHA512 ff085fb38c13cf1b05dde6acf7ec091c211c043f73c094693ebf58b1b5d5a4db58de1d55576af88cafab37d4d87824a4c38817d04c14d4c196efacf8de678912 WHIRLPOOL 6699c92aee79f3ec79a0748c985fe7511f1c24b8001231ac2e262a17928295b3f960dd92003b4573e7bf035b03e1d7ec0f9a95e58bf00bc149a505f90499f0bc
+EBUILD influxdb-0.13.0.ebuild 723 SHA256 742df0f04d8d82d2eeab90689de0982dd26a711d5a3110ce2bfeaef3d3d906ae SHA512 6efe3b6a4b0515e675c42a196c2dd871aabb6437980d7fc9bef844ad222aee4dbdee754aacd977836d5e8a3e80df014e7373796086eabac89161a3d10a9312b0 WHIRLPOOL 0a92ee9346bad9a7738ac16dc10ac445fb97c5372725da64ceffaace2131b1e4fb3cc30a87fe6ebc19cbb131432f50a110b137f8bd71f4a602e307109bce8104
diff --git a/dev-db/influxdb/files/influxdb.conf.d b/dev-db/influxdb/files/influxdb.conf.d
new file mode 100644
index 0000000..660eb2b
--- /dev/null
+++ b/dev-db/influxdb/files/influxdb.conf.d
@@ -0,0 +1,3 @@
+# /etc/conf.d/influxdb: configuration for /etc/init.d/influxdb
+
+INFLUXD_OPTS=""
diff --git a/dev-db/influxdb/files/influxdb.init.d b/dev-db/influxdb/files/influxdb.init.d
new file mode 100644
index 0000000..165a6c5
--- /dev/null
+++ b/dev-db/influxdb/files/influxdb.init.d
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+description="Scalable datastore for metrics, events, and real-time analytics"
+
+user="influxdb:influxdb"
+logfile="/var/log/influxdb/influxd.log"
+start_stop_daemon_args="--user $user --stdout $logfile --stderr $logfile"
+
+command="/usr/bin/influxd"
+command_args="
+ -config /etc/influxdb/influxdb.conf
+ ${INFLUXD_OPTS}
+"
+
+command_background=yes
+pidfile=/run/influxdb.pid
+
+
+depend() {
+ need net
+ after bootmisc
+}
+
+start_pre() {
+ checkpath --file --owner $user --mode 0644 $logfile
+ checkpath --directory --owner $user --mode 0755 /var/lib/influxdb
+}
diff --git a/dev-db/influxdb/influxdb-0.13.0.ebuild b/dev-db/influxdb/influxdb-0.13.0.ebuild
new file mode 100644
index 0000000..2a6907b
--- /dev/null
+++ b/dev-db/influxdb/influxdb-0.13.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit user unpacker
+
+DESCRIPTION="Scalable datastore for metrics, events, and real-time analytics"
+HOMEPAGE="http://influxdb.com"
+SRC_URI="https://dl.influxdata.com/influxdb/releases/${PN}_${PV}_amd64.deb"
+
+RESTRICT="mirror"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 "/var/lib/${PN}" ${PN}
+}
+
+src_unpack() {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ unpack_deb ${A}
+}
+
+src_install() {
+ cp -Rp * "${D}"
+ newconfd "${FILESDIR}/${PN}.conf.d" "${PN}"
+ newinitd "${FILESDIR}/${PN}.init.d" "${PN}"
+}