summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/bup-0.25_rc1.ebuild')
-rw-r--r--app-backup/bup/bup-0.25_rc1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-backup/bup/bup-0.25_rc1.ebuild b/app-backup/bup/bup-0.25_rc1.ebuild
new file mode 100644
index 0000000..eaeb0b9
--- /dev/null
+++ b/app-backup/bup/bup-0.25_rc1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="It backs things up based on the git packfile format"
+HOMEPAGE="http://github.com/apenwarr/bup"
+SRC_URI="https://github.com/apenwarr/${PN}/tarball/${P/_/-} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+doc"
+
+DEPEND="|| (
+ dev-lang/python:2.4
+ dev-lang/python:2.5
+ dev-lang/python:2.6
+ dev-lang/python:2.7
+ )
+ dev-vcs/git
+ app-arch/par2cmdline
+ dev-python/fuse-python
+ doc? ( app-text/pandoc )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv -v * "${S}" || die
+}
+
+src_configure() {
+ # bup doesn't accept --build= option
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/"$(get_libdir)"
+
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ dodoc "${D}/usr/share/doc/${PN}"/*
+ rm -r "${D}/usr/share/doc/${PN}/" || die
+
+ dodoc README DESIGN
+}
+
+src_test() {
+ emake test
+}