summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2010-08-22 14:38:28 +0200
committerDomen Kožar <domen@dev.si>2010-08-22 14:38:28 +0200
commit73a7a5de14727e0b5039d452a3c57841605a08a3 (patch)
tree1d3bd319815bbea37e40b85e8d3caf041226e5ba
parentversion bump jaxml to 3.02 (diff)
downloadiElectric-73a7a5de14727e0b5039d452a3c57841605a08a3.tar.gz
iElectric-73a7a5de14727e0b5039d452a3c57841605a08a3.tar.bz2
iElectric-73a7a5de14727e0b5039d452a3c57841605a08a3.zip
add scripttest
-rw-r--r--dev-python/scripttest/ChangeLog10
-rw-r--r--dev-python/scripttest/Manifest3
-rw-r--r--dev-python/scripttest/metadata.xml6
-rw-r--r--dev-python/scripttest/scripttest-1.1.ebuild29
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/scripttest/ChangeLog b/dev-python/scripttest/ChangeLog
new file mode 100644
index 0000000..7aef7fe
--- /dev/null
+++ b/dev-python/scripttest/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/scripttest
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*scripttest-1.1 (22 Aug 2010)
+
+ 22 Aug 2010; Domen Kožar <domen@dev.si> +scripttest-1.1.ebuild,
+ +metadata.xml:
+ Initial commit
+
diff --git a/dev-python/scripttest/Manifest b/dev-python/scripttest/Manifest
new file mode 100644
index 0000000..c0d01cd
--- /dev/null
+++ b/dev-python/scripttest/Manifest
@@ -0,0 +1,3 @@
+DIST ScriptTest-1.1.tar.gz 7192 RMD160 0d73a88e21f142d82171eaa31a001bfd61c74779 SHA1 06166a35f1f9ec0c9da4d3c3afdcaf71d762dfc5 SHA256 3da2d74929d4e9a5d87c683680b09c780fccabfa188108867c5f67c1ea3918dd
+EBUILD scripttest-1.1.ebuild 655 RMD160 b3aa7ce73a2626fc23ed595fdbf96c40a635385f SHA1 29bc0c9d177cc4c4c3df2c94cd94f6cc565cd1b7 SHA256 9f29a81367673edbf3f43a9cc7c03a497df7fdfe07629ea226233048def7afaa
+MISC metadata.xml 198 RMD160 6a84cce6c68e9428224430cce679e9884faedf66 SHA1 46810b7767dedd534650c053f8e512e6bb81e1df SHA256 a6cced7fd655d4e5e10239d91957eb486c00169084460d93433922262241bcab
diff --git a/dev-python/scripttest/metadata.xml b/dev-python/scripttest/metadata.xml
new file mode 100644
index 0000000..0923903
--- /dev/null
+++ b/dev-python/scripttest/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/dev-python/scripttest/scripttest-1.1.ebuild b/dev-python/scripttest/scripttest-1.1.ebuild
new file mode 100644
index 0000000..d6b8c54
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.1
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="ScriptTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test command-line scripts"
+HOMEPAGE="http://pythonpaste.org/scripttest/"
+SRC_URI="http://pypi.python.org/packages/source/S/ScriptTest/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="test unittest doctest command line scripts"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-python/setuptools
+ test? ( dev-python/nose )"
+
+S="${WORKDIR}/${MY_P}"
+