summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2020-02-19 16:24:27 +0100
committerhaarp <main.haarp@gmail.com>2020-02-19 16:38:02 +0100
commit237be8032b89b30b29132cfe63b7f83b201b2783 (patch)
tree05086d2708c45626e799753f3c93ab9c25900f5a /x11-misc
parentUpdate multiload-ng and fix NVMe/DM support (diff)
downloadhaarp-237be8032b89b30b29132cfe63b7f83b201b2783.tar.gz
haarp-237be8032b89b30b29132cfe63b7f83b201b2783.tar.bz2
haarp-237be8032b89b30b29132cfe63b7f83b201b2783.zip
Add gtk3-nocsd
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/gtk3-nocsd/Manifest1
-rw-r--r--x11-misc/gtk3-nocsd/gtk3-nocsd-9999.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/gtk3-nocsd/Manifest b/x11-misc/gtk3-nocsd/Manifest
new file mode 100644
index 0000000..47c9528
--- /dev/null
+++ b/x11-misc/gtk3-nocsd/Manifest
@@ -0,0 +1 @@
+EBUILD gtk3-nocsd-9999.ebuild 806 BLAKE2B 127e11c9a8d421ed9211b44a378df5af6ddd8b0b6a3a7d959149b06e94511e528d67f5b1d3a9aab823954a81410fbbcd3dc0c4d43c52c7f5bef21e49665b1c3c SHA512 07f5207297fd75d2c86ac480aa500572c3c1a630afffc2de29d74712e263259515df5c831ac3997159c8e7d19f43aafc9f47a6ef87199712ee745e494f42f7c6
diff --git a/x11-misc/gtk3-nocsd/gtk3-nocsd-9999.ebuild b/x11-misc/gtk3-nocsd/gtk3-nocsd-9999.ebuild
new file mode 100644
index 0000000..0a05644
--- /dev/null
+++ b/x11-misc/gtk3-nocsd/gtk3-nocsd-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib git-r3
+
+DESCRIPTION="Hack to disable GTK+-3 client-side decorations"
+HOMEPAGE="https://github.com/PCMan/gtk3-nocsd"
+
+EGIT_REPO_URI="https://github.com/PCMan/gtk3-nocsd.git"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+LICENSE="GPL-2"
+
+DEPEND="x11-libs/gtk+:3"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ # maybe also consider /debian/extra from Ubuntu pkg like the Unity overlay ebuild?
+
+ emake prefix="${D}/usr" libdir="${D}/usr/$(get_libdir)" install
+
+ einfo "Add to your ~/.profile and re-login:"
+ einfo " export GTK_CSD=0"
+ einfo " export LD_PRELOAD=\"${EROOT%/}/usr/$(get_libdir)/libgtk3-nocsd.so.0 \$LD_PRELOAD\""
+ einfo "Or prefix your commands with:"
+ einfo " gtk3-nocsd"
+}