aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.7.6-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.7.6-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/python/python-2.7.6-r1.ebuild b/dev-lang/python/python-2.7.6-r1.ebuild
index b0e4085..20506d4 100644
--- a/dev-lang/python/python-2.7.6-r1.ebuild
+++ b/dev-lang/python/python-2.7.6-r1.ebuild
@@ -9,7 +9,7 @@ WANT_LIBTOOL="none"
inherit autotools eutils flag-o-matic multilib pax-utils python-multilib-utils-r1 toolchain-funcs multiprocessing multilib-minimal
MY_P="Python-${PV}"
-PATCHSET_REVISION="0"
+PATCHSET_REVISION="1"
DESCRIPTION="An interpreted, interactive, object-oriented programming language"
HOMEPAGE="http://www.python.org/"
@@ -190,6 +190,12 @@ src_configure() {
use hardened && replace-flags -O3 -O2
fi
+ if tc-is-cross-compiler; then
+ # Force some tests that try to poke fs paths.
+ export ac_cv_file__dev_ptc=no
+ export ac_cv_file__dev_ptmx=yes
+ fi
+
local dbmliborder
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"