summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/vte/vte-0.34.8.ebuild')
-rw-r--r--x11-libs/vte/vte-0.34.8.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/x11-libs/vte/vte-0.34.8.ebuild b/x11-libs/vte/vte-0.34.8.ebuild
deleted file mode 100644
index a9e4c36..0000000
--- a/x11-libs/vte/vte-0.34.8.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.34.8.ebuild,v 1.1 2013/09/28 20:48:59 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="Library providing a virtual terminal emulator widget"
-HOMEPAGE="https://live.gnome.org/Terminal/VTE"
-
-LICENSE="LGPL-2+"
-SLOT="2.90"
-IUSE="debug glade +introspection termite-patch"
-KEYWORDS="~amd64 ~x86"
-
-PDEPEND="=x11-libs/gnome-pty-helper-${PV}"
-RDEPEND="
- >=dev-libs/glib-2.31.13:2
- >=x11-libs/gtk+-3.1.9:3[introspection?]
- >=x11-libs/pango-1.22.0
-
- sys-libs/ncurses
- x11-libs/libX11
- x11-libs/libXft
-
- glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_prepare() {
- if [[ ${CHOST} == *-interix* ]]; then
- G2CONF="${G2CONF} --disable-Bsymbolic"
-
- # interix stropts.h is empty...
- export ac_cv_header_stropts_h=no
- fi
-
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=663779
- epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
-
- use termite-patch && epatch "${FILESDIR}"/${PN}-0.32.2-expose_select_text.patch
-
- gnome2_src_prepare
-}
-
-src_configure() {
- # Python bindings are via gobject-introspection
- # Ex: from gi.repository import Vte
- # Do not disable gnome-pty-helper, bug #401389
- gnome2_src_configure \
- --disable-deprecation \
- --disable-static \
- $(use_enable debug) \
- $(use_enable glade glade-catalogue) \
- $(use_enable introspection)
-}
-
-src_install() {
- gnome2_src_install
- rm -v "${ED}usr/libexec/gnome-pty-helper" || die
-}