summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/udevil/files/udevil-0.2.9-flags.patch')
-rw-r--r--sys-apps/udevil/files/udevil-0.2.9-flags.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/udevil/files/udevil-0.2.9-flags.patch b/sys-apps/udevil/files/udevil-0.2.9-flags.patch
new file mode 100644
index 0000000..dc7d09c
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.2.9-flags.patch
@@ -0,0 +1,61 @@
+From: Elijah El Lazkani <ThyArmageddon+Gentoo@Gmail.com>
+Date: Wed Jun 13 22:45:09 UTC 2012
+Subject: Removing explicit LDFLAGS and CPPFLAGS
+
+--- configure.ac
++++ configure.ac
+@@ -16,42 +16,6 @@
+ AC_DEFINE_UNQUOTED(UDEVIL_VERSION, "$VERSION", [udevil version])
+
+
+-dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+-case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-Bsymbolic-functions"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -16,8 +16,7 @@
+
+ udevil_CFLAGS = \
+ @GLIB_CFLAGS@ \
+- @LIBUDEV_CFLAGS@ \
+- -Werror-implicit-function-declaration
++ @LIBUDEV_CFLAGS@
+
+ udevil_LDADD = \
+ $(INTLLIBS) \