summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-07-13 20:56:46 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-07-13 20:56:46 -0400
commit1d6d9cf2e26872f8144bb4074c3d19ed1bef064e (patch)
treecf52e559ef262bd53ce58dd6ab663fe55bc109be /games-action
parentsyntax error (diff)
downloadsuperposition-1d6d9cf2e26872f8144bb4074c3d19ed1bef064e.tar.gz
superposition-1d6d9cf2e26872f8144bb4074c3d19ed1bef064e.tar.bz2
superposition-1d6d9cf2e26872f8144bb4074c3d19ed1bef064e.zip
Raft
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Raft/Manifest3
-rw-r--r--games-action/Raft/Raft-1.04.ebuild48
-rw-r--r--games-action/Raft/metadata.xml10
3 files changed, 61 insertions, 0 deletions
diff --git a/games-action/Raft/Manifest b/games-action/Raft/Manifest
new file mode 100644
index 0000000..0b5753c
--- /dev/null
+++ b/games-action/Raft/Manifest
@@ -0,0 +1,3 @@
+DIST V1.04_Raft_LinuxUniversal.zip 94838013 SHA256 bd2bbefd37ce9b1e90a94cd2b74bdd47a0dbef7988572ad1629ed1f495cd9384 SHA512 9543c4a244406276c31927693e7e4cd9a49d5e7bf97ea2a07faaaff1c0ed611cd1b67aca1296d626e155b2ef7d3895adf5c186da1f76208b9ac9e9b750f7ed33 WHIRLPOOL 01545a9d1990547b3f4a78d5c0927f010e8db1c637b99934a4e7cd1d544e759835f26a663b9399652a43bfd54c9354f15028320bfe243ec472cee84c2a6650b9
+EBUILD Raft-1.04.ebuild 1146 SHA256 55e4f16c796be4d516aa8b36002459db1214b39bdbe207df34bad4afe686c7d9 SHA512 1f0eb0b82b5146ccd7248242c1e055a026f38b7e93d35c8ef3a5a8763475bff15fb2365a15e7eb7ac58116c08e395fb9437dc1d20f627fe1802bde457ae71958 WHIRLPOOL f78c2c99f3ed5868d009627d28a9e9672a5db631495c0e8c7454f1c3effc6e2aa75e36ecebd6f7272e84d76c9dfd95468cb1df99c27db21e5d8cbcc413b0fd33
+MISC metadata.xml 296 SHA256 779b294381e01cc6a37ca7c51f0bc1087b6a27d2fbf9d7a01b915284f52101e2 SHA512 c2c2249b7f8796c8e24a4487c8443d1c11f034b223a041269a6aead71d197dba6d692a653b7ddfbd56e6a664b5682afb9a892e6650003960b43b8b667d13e53b WHIRLPOOL e4170ee562b45e995707cf78c7b14123cad43d8f0ca500e3ae1b508085754da38b431a1436839c99842fc4eb014255cce1f9d448e8792aa25b7f7c4811ee78db
diff --git a/games-action/Raft/Raft-1.04.ebuild b/games-action/Raft/Raft-1.04.ebuild
new file mode 100644
index 0000000..c75c575
--- /dev/null
+++ b/games-action/Raft/Raft-1.04.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit unpacker eutils
+
+DESCRIPTION="Survive the harsh life of being stuck on a raft in the middle of the ocean!"
+HOMEPAGE="https://raft.itch.io/raft"
+SRC_URI="V${PVR}_${PN}_LinuxUniversal.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist fetch"
+
+MYGAMEDIR=/opt/${PN}
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ insinto ${MYGAMEDIR}
+ exeinto ${MYGAMEDIR}
+ doexe "V1.04_Raft_LinuxUniversal/V1.04_Raft_LinuxUniversal.x86_64"
+ newicon -s 128 "V1.04_Raft_LinuxUniversal/V1.04_Raft_LinuxUniversal_Data/Resources/UnityPlayer.png" "${PN}.png"
+
+ doins -r "V1.04_Raft_LinuxUniversal/V1.04_Raft_LinuxUniversal_Data"
+ make_wrapper ${PN} "./V1.04_Raft_LinuxUniversal.x86_64" "${MYGAMEDIR}"
+ make_desktop_entry "${PN}" "Raft" "${PN}" "Game"
+
+ domenu ${PN}
+
+}
diff --git a/games-action/Raft/metadata.xml b/games-action/Raft/metadata.xml
new file mode 100644
index 0000000..e895951
--- /dev/null
+++ b/games-action/Raft/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>Phil_Miess@yahoo.com</email>
+</maintainer>
+<longdescription lang="en">
+A game about surviving on a raft
+</longdescription>
+</pkgmetadata>