summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/hyprlang/hyprlang-9999.ebuild')
-rw-r--r--dev-libs/hyprlang/hyprlang-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/hyprlang/hyprlang-9999.ebuild b/dev-libs/hyprlang/hyprlang-9999.ebuild
new file mode 100644
index 0000000..08ee820
--- /dev/null
+++ b/dev-libs/hyprlang/hyprlang-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023-2024 Gentoo Authors
+# Copyright 2024 John M. Harris, Jr.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Official implementation library for the hypr config language"
+HOMEPAGE="https://github.com/hyprwm/hyprlang"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"