aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-11-16 01:15:04 +0100
committerMarco Leise <marco.leise@gmx.de>2020-11-16 05:02:17 +0100
commit81454b377a022f7f2661196af0105b3cda52982f (patch)
treecc5b4d92475aa35ba56aadbb94ee33825cf8be48 /dev-lang
parentonedrive-2.4.5 (diff)
downloaddlang-81454b377a022f7f2661196af0105b3cda52982f.tar.gz
dlang-81454b377a022f7f2661196af0105b3cda52982f.tar.bz2
dlang-81454b377a022f7f2661196af0105b3cda52982f.zip
stabilization sweep
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/dmd/dmd-2.092.1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.18.0-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.18.0.ebuild82
-rw-r--r--dev-lang/ldc2/ldc2-1.19.0-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.19.0.ebuild81
-rw-r--r--dev-lang/ldc2/ldc2-1.20.1-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.20.1.ebuild82
-rw-r--r--dev-lang/ldc2/ldc2-1.21.0-r1.ebuild2
-rw-r--r--dev-lang/ldc2/ldc2-1.21.0.ebuild82
-rw-r--r--dev-lang/ldc2/ldc2-1.22.0.ebuild2
10 files changed, 6 insertions, 333 deletions
diff --git a/dev-lang/dmd/dmd-2.092.1.ebuild b/dev-lang/dmd/dmd-2.092.1.ebuild
index 3de9271..41237d0 100644
--- a/dev-lang/dmd/dmd-2.092.1.ebuild
+++ b/dev-lang/dmd/dmd-2.092.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* amd64 x86"
YEAR=2020
DLANG_VERSION_RANGE="2.076-"
diff --git a/dev-lang/ldc2/ldc2-1.18.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.18.0-r1.ebuild
index 0949633..78869a1 100644
--- a/dev-lang/ldc2/ldc2-1.18.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.18.0-r1.ebuild
@@ -12,7 +12,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="LLVM D Compiler"
HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="BSD"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
diff --git a/dev-lang/ldc2/ldc2-1.18.0.ebuild b/dev-lang/ldc2/ldc2-1.18.0.ebuild
deleted file mode 100644
index f78e20c..0000000
--- a/dev-lang/ldc2/ldc2-1.18.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake-utils llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 3.9 through 9.
-RDEPEND="|| (
- sys-devel/llvm:9
- )
- <sys-devel/llvm-10:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND=">=dev-util/cmake-3.8
- dev-util/ninja
- ${RDEPEND}"
-LLVM_MAX_SLOT=9
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch\
- ${FILESDIR}/ldc2-1.18.0-FileCheck-not.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.068 2.071-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=', "-relocation-model=pic"' )
- cmake-utils_src_configure
-}
-
-d_src_compile() {
- cmake-utils_src_make
-}
-
-d_src_install() {
- cmake-utils_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.19.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.19.0-r1.ebuild
index efd604c..c5f891a 100644
--- a/dev-lang/ldc2/ldc2-1.19.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.19.0-r1.ebuild
@@ -12,7 +12,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="LLVM D Compiler"
HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="BSD"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
diff --git a/dev-lang/ldc2/ldc2-1.19.0.ebuild b/dev-lang/ldc2/ldc2-1.19.0.ebuild
deleted file mode 100644
index 4f8333a..0000000
--- a/dev-lang/ldc2/ldc2-1.19.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake-utils llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 3.9 through 9.
-RDEPEND="|| (
- sys-devel/llvm:9
- )
- <sys-devel/llvm-10:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND=">=dev-util/cmake-3.8
- dev-util/ninja
- ${RDEPEND}"
-LLVM_MAX_SLOT=9
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.068 2.071-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=', "-relocation-model=pic"' )
- cmake-utils_src_configure
-}
-
-d_src_compile() {
- cmake-utils_src_make
-}
-
-d_src_install() {
- cmake-utils_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.20.1-r1.ebuild b/dev-lang/ldc2/ldc2-1.20.1-r1.ebuild
index b66cc3f..2892042 100644
--- a/dev-lang/ldc2/ldc2-1.20.1-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.20.1-r1.ebuild
@@ -12,7 +12,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="LLVM D Compiler"
HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="BSD"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
diff --git a/dev-lang/ldc2/ldc2-1.20.1.ebuild b/dev-lang/ldc2/ldc2-1.20.1.ebuild
deleted file mode 100644
index 006204a..0000000
--- a/dev-lang/ldc2/ldc2-1.20.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake-utils llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 3.9 through 10.
-RDEPEND="|| (
- sys-devel/llvm:10
- sys-devel/llvm:9
- )
- <sys-devel/llvm-11:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND=">=dev-util/cmake-3.8
- dev-util/ninja
- ${RDEPEND}"
-LLVM_MAX_SLOT=10
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=', "-relocation-model=pic"' )
- cmake-utils_src_configure
-}
-
-d_src_compile() {
- cmake-utils_src_make
-}
-
-d_src_install() {
- cmake-utils_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.21.0-r1.ebuild b/dev-lang/ldc2/ldc2-1.21.0-r1.ebuild
index b66cc3f..2892042 100644
--- a/dev-lang/ldc2/ldc2-1.21.0-r1.ebuild
+++ b/dev-lang/ldc2/ldc2-1.21.0-r1.ebuild
@@ -12,7 +12,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="LLVM D Compiler"
HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="BSD"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
diff --git a/dev-lang/ldc2/ldc2-1.21.0.ebuild b/dev-lang/ldc2/ldc2-1.21.0.ebuild
deleted file mode 100644
index 006204a..0000000
--- a/dev-lang/ldc2/ldc2-1.21.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake-utils llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# We support LLVM 3.9 through 10.
-RDEPEND="|| (
- sys-devel/llvm:10
- sys-devel/llvm:9
- )
- <sys-devel/llvm-11:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND=">=dev-util/cmake-3.8
- dev-util/ninja
- ${RDEPEND}"
-LLVM_MAX_SLOT=10
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-DLANG_VERSION_RANGE="2.075-"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-detect_hardened() {
- gcc --version | grep -o Hardened
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD}"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- detect_hardened && mycmakeargs+=( -DADDITIONAL_DEFAULT_LDC_SWITCHES=', "-relocation-model=pic"' )
- cmake-utils_src_configure
-}
-
-d_src_compile() {
- cmake-utils_src_make
-}
-
-d_src_install() {
- cmake-utils_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
diff --git a/dev-lang/ldc2/ldc2-1.22.0.ebuild b/dev-lang/ldc2/ldc2-1.22.0.ebuild
index b66cc3f..2892042 100644
--- a/dev-lang/ldc2/ldc2-1.22.0.ebuild
+++ b/dev-lang/ldc2/ldc2-1.22.0.ebuild
@@ -12,7 +12,7 @@ S=${WORKDIR}/${MY_P}
DESCRIPTION="LLVM D Compiler"
HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
LICENSE="BSD"
SLOT="$(ver_cut 1-2)/$(ver_cut 3)"