aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-06-01 21:51:14 +0300
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-06-01 22:21:21 +0300
commitae6638ae8f109ca1c6e89450bdc538a7fa299be2 (patch)
treef693b06489c112942247026a9c5bd358a177926e
parentdev-util/dub: enable ldc2-1_38 (diff)
downloaddlang-ae6638ae8f109ca1c6e89450bdc538a7fa299be2.tar.gz
dlang-ae6638ae8f109ca1c6e89450bdc538a7fa299be2.tar.bz2
dlang-ae6638ae8f109ca1c6e89450bdc538a7fa299be2.zip
dev-util/dub: enable gdc-14
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
-rw-r--r--dev-util/dub/dub-1.37.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/dub/dub-1.37.0.ebuild b/dev-util/dub/dub-1.37.0.ebuild
index d1dc510..c998570 100644
--- a/dev-util/dub/dub-1.37.0.ebuild
+++ b/dev-util/dub/dub-1.37.0.ebuild
@@ -36,7 +36,7 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
-DLANG_COMPAT=( dmd-2_{106..108} gdc-13 ldc2-1_{35..38} )
+DLANG_COMPAT=( dmd-2_{106..108} gdc-1{3,4} ldc2-1_{35..38} )
inherit dlang-single shell-completion
@@ -84,7 +84,7 @@ src_compile() {
# Fixed in >=sys-devel/gcc-13.2.1_p20240330. Adding -mno-sse2 makes
# tests fail so defer to removing the common way users get avx
# instructions enabled (-march=native) and warn them.
- if [[ ${ARCH} == amd64 && ${EDC} == gdc* && ${DCFLAGS} == *-march=native* ]]; then
+ if [[ ${ARCH} == amd64 && ${EDC} == gdc-13 && ${DCFLAGS} == *-march=native* ]]; then
ewarn "<sys-devel/gcc-13.2.1_p20240330 is known to generate invalid code"
ewarn "on amd64 with certain flags. For this reason -march=native will be"
ewarn "removed from your flags. Feel free to use -march=<cpu> to bypass this"
@@ -132,7 +132,7 @@ src_test() {
# We have an importC test and not all compilers pass it properly.
# gdc doesn't support #include's in its importC implementation yet.
# Only check == 13 since 12 is skipped by the script.
- [[ ${EDC} == gdc* ]] && [[ $(dlang_get_be_version) == 13 ]] && dropImportCTest=1
+ [[ ${EDC} == gdc-13 ]] && dropImportCTest=1
# Nor does <=ldc2-1.32.
[[ ${EDC} == ldc* ]] && $(ver_test $(dlang_get_be_version) -le 1.32) && dropImportCTest=1
# dmd can do #include's but there are some other errors about