summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch')
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch b/dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch
new file mode 100644
index 0000000..f7c8543
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.2.34.1-system_harfbuzz.patch
@@ -0,0 +1,23 @@
+diff -uNr a/laf/CMakeLists.txt b/laf/CMakeLists.txt
+--- a/laf/CMakeLists.txt 2021-12-01 22:06:08.000000000 +0100
++++ b/laf/CMakeLists.txt 2022-02-15 18:05:31.640137967 +0100
+@@ -44,13 +44,12 @@
+ # Find libraries
+ if(LAF_BACKEND STREQUAL "skia")
+ include(FindSkia)
+-else()
+- if(NOT FREETYPE_LIBRARIES)
+- find_package(Freetype)
+- endif()
+- if(NOT HARFBUZZ_LIBRARIES)
+- find_package(HarfBuzz)
+- endif()
++endif()
++if(NOT FREETYPE_LIBRARIES)
++ find_package(Freetype)
++endif()
++if(NOT HARFBUZZ_LIBRARIES)
++ find_package(HarfBuzz)
+ endif()
+
+ add_subdirectory(third_party)