summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-390.143-r1.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.143-r1.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.143-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.143-r1.ebuild
index 8cb722145a59..233548975b04 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.143-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.143-r1.ebuild
@@ -385,4 +385,20 @@ pkg_postinst() {
elog "Support for EGLStream (egl-wayland) is no longer offered with legacy"
elog "nvidia-drivers. It is recommended to use nouveau drivers for wayland."
fi
+
+ # Try to show this message only to users that may really need it
+ # given the workaround is discouraged and usage isn't widespread.
+ if use X && [[ ${REPLACING_VERSIONS} ]] &&
+ ver_test ${REPLACING_VERSIONS} -lt 390.143 &&
+ grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
+ elog
+ elog "Coolbits support with ${PN} has been restricted to require Xorg"
+ elog "with root privilege by NVIDIA (being in video group is not sufficient)."
+ elog "e.g. attempting to change fan speed with nvidia-settings would fail."
+ elog
+ elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
+ elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
+ elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
+ elog "Bug: https://bugs.gentoo.org/784248"
+ fi
}