summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-234.ebuild')
-rw-r--r--sys-apps/systemd/systemd-234.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-apps/systemd/systemd-234.ebuild b/sys-apps/systemd/systemd-234.ebuild
index 29d13ba5bf10..c80965e1c39f 100644
--- a/sys-apps/systemd/systemd-234.ebuild
+++ b/sys-apps/systemd/systemd-234.ebuild
@@ -436,6 +436,11 @@ pkg_postinst() {
ewarn "You should replace the resolv.conf symlink:"
ewarn "ln -snf ${ROOTPREFIX%/}/lib/systemd/resolv.conf ${ROOT}etc/resolv.conf"
fi
+
+ if [[ -e "${EROOT%/}"/usr/lib/systemd/system-generators ]]; then
+ ewarn "Please rebuild any packages which install system generators."
+ ewarn " emerge --oneshot --usepkg=n /usr/lib/systemd/system-generators"
+ fi
}
pkg_prerm() {