summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/irqbalance/irqbalance-1.0.7.ebuild')
-rw-r--r--sys-apps/irqbalance/irqbalance-1.0.7.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-apps/irqbalance/irqbalance-1.0.7.ebuild b/sys-apps/irqbalance/irqbalance-1.0.7.ebuild
deleted file mode 100644
index 7dcc8525bb65..000000000000
--- a/sys-apps/irqbalance/irqbalance-1.0.7.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils systemd linux-info
-
-DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
-HOMEPAGE="https://github.com/Irqbalance/irqbalance"
-SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="caps +numa"
-
-RDEPEND="dev-libs/glib:2
- caps? ( sys-libs/libcap-ng )
- numa? ( sys-process/numactl )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-pkg_setup() {
- CONFIG_CHECK="~PCI_MSI"
- linux-info_pkg_setup
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with caps libcap-ng)
- $(use_enable numa)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
- newinitd "${FILESDIR}"/irqbalance.init.3 irqbalance
- newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
- systemd_dounit "${FILESDIR}"/irqbalance.service
-}