summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch118
1 files changed, 0 insertions, 118 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch b/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch
deleted file mode 100644
index aa6a9b23fdec..000000000000
--- a/sci-mathematics/rstudio/files/rstudio-1.2.5033-paths.patch
+++ /dev/null
@@ -1,118 +0,0 @@
---- rstudio-1.2.5033-orig/CMakeGlobals.txt 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/CMakeGlobals.txt 2020-01-07 12:20:19.115307754 +1100
-@@ -175,7 +175,7 @@
- else()
- set(RSTUDIO_INSTALL_BIN bin)
- endif()
-- set(RSTUDIO_INSTALL_SUPPORTING .)
-+ set(RSTUDIO_INSTALL_SUPPORTING ${DISTRO_SHARE})
- endif()
-
- # if the install prefix is /usr/local then tweak as appropriate
---- rstudio-1.2.5033-orig/src/cpp/server/CMakeLists.txt 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/server/CMakeLists.txt 2020-01-07 12:17:32.736309024 +1100
-@@ -194,7 +194,7 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT})
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_DEBIAN_SCRIPT}
-- DESTINATION ${RSERVER_INITD_DEBIAN_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_DEBIAN_DIR})
-
- # install configured redhat init.d script
- set(RSERVER_INITD_REDHAT_DIR "extras/init.d/redhat")
-@@ -202,7 +202,7 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT})
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_REDHAT_SCRIPT}
-- DESTINATION ${RSERVER_INITD_REDHAT_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_REDHAT_DIR})
-
- # install configured suse init.d script
- set(RSERVER_INITD_SUSE_DIR "extras/init.d/suse")
-@@ -210,13 +210,13 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_INITD_SUSE_SCRIPT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT})
- install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_INITD_SUSE_SCRIPT}
-- DESTINATION ${RSERVER_INITD_SUSE_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_INITD_SUSE_DIR})
-
- # install pam profile
- set(RSERVER_PAM_DIR "extras/pam")
- set(RSERVER_PAM_PROFILE "${RSERVER_PAM_DIR}/rstudio")
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_PAM_PROFILE}
-- DESTINATION ${RSERVER_PAM_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_PAM_DIR})
-
- # install configured upstart profile
- set(RSERVER_UPSTART_DIR "extras/upstart")
-@@ -224,12 +224,12 @@
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE}
-- DESTINATION ${RSERVER_UPSTART_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
- set(RSERVER_UPSTART_PROFILE_REDHAT "${RSERVER_UPSTART_DIR}/rstudio-server.redhat.conf")
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}.in
- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT})
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_UPSTART_PROFILE_REDHAT}
-- DESTINATION ${RSERVER_UPSTART_DIR})
-+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
-
- # install configured systemd profile
- set(RSERVER_SYSTEMD_DIR "extras/systemd")
---- rstudio-1.2.5033-orig/src/cpp/server/ServerOptions.cpp 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/server/ServerOptions.cpp 2020-01-07 12:17:32.773309023 +1100
-@@ -389,8 +389,8 @@
-
- // convert relative paths by completing from the system installation
- // path (this allows us to be relocatable)
-- resolvePath(resourcePath, &wwwLocalPath_);
-- resolvePath(resourcePath, &wwwSymbolMapsPath_);
-+ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwLocalPath_);
-+ resolvePath(resourcePath.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
- resolvePath(binaryPath, &authPamHelperPath_);
- resolvePath(binaryPath, &rsessionPath_);
- resolvePath(binaryPath, &rldpathPath_);
---- rstudio-1.2.5033-orig/src/cpp/session/SessionOptions.cpp 2019-12-04 17:22:17.000000000 +1100
-+++ rstudio-1.2.5033/src/cpp/session/SessionOptions.cpp 2020-01-07 12:17:32.774309023 +1100
-@@ -53,7 +53,7 @@
- namespace session {
-
- namespace {
--const char* const kDefaultPandocPath = "bin/pandoc";
-+const char* const kDefaultPandocPath = "bin";
- const char* const kDefaultPostbackPath = "bin/postback/rpostback";
- const char* const kDefaultRsclangPath = "bin/rsclang";
-
-@@ -571,14 +571,14 @@
- }
-
- // convert relative paths by completing from the app resource path
-- resolvePath(resourcePath_, &rResourcesPath_);
-- resolvePath(resourcePath_, &agreementFilePath_);
-- resolvePath(resourcePath_, &wwwLocalPath_);
-- resolvePath(resourcePath_, &wwwSymbolMapsPath_);
-- resolvePath(resourcePath_, &coreRSourcePath_);
-- resolvePath(resourcePath_, &modulesRSourcePath_);
-- resolvePath(resourcePath_, &sessionLibraryPath_);
-- resolvePath(resourcePath_, &sessionPackageArchivesPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &rResourcesPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &agreementFilePath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwLocalPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &wwwSymbolMapsPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &coreRSourcePath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &modulesRSourcePath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionLibraryPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &sessionPackageArchivesPath_);
- resolvePostbackPath(resourcePath_, &rpostbackPath_);
- #ifdef _WIN32
- resolvePath(resourcePath_, &consoleIoPath_);
-@@ -611,7 +611,7 @@
- }
- winptyPath_ = pty.complete(completion).absolutePath();
- #endif // _WIN32
-- resolvePath(resourcePath_, &hunspellDictionariesPath_);
-+ resolvePath(resourcePath_.childPath(DISTRO_SHARE), &hunspellDictionariesPath_);
- resolvePath(resourcePath_, &mathjaxPath_);
- resolvePath(resourcePath_, &libclangHeadersPath_);
- resolvePandocPath(resourcePath_, &pandocPath_);