summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/dealii/dealii-9999.ebuild')
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 35dcbc94b523..2d31d5890b97 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,9 +34,9 @@ LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="
adolc assimp arpack cpu_flags_x86_avx cpu_flags_x86_avx512f
- cpu_flags_x86_sse2 cuda +debug doc +examples gmsh +gsl hdf5 +lapack
- metis mpi muparser nanoflann opencascade netcdf p4est petsc scalapack
- slepc +sparse static-libs sundials symengine +tbb trilinos
+ cpu_flags_x86_sse2 cuda +debug doc +examples ginkgo gmsh +gsl hdf5
+ +lapack metis mpi muparser nanoflann opencascade netcdf p4est petsc
+ scalapack slepc +sparse static-libs sundials symengine +tbb trilinos
"
# TODO: add slepc use flag once slepc is packaged for gentoo-science
@@ -52,6 +52,7 @@ RDEPEND="dev-libs/boost
arpack? ( sci-libs/arpack[mpi=] )
assimp? ( media-libs/assimp )
cuda? ( dev-util/nvidia-cuda-sdk )
+ ginkgo? ( sci-libs/ginkgo )
gmsh? ( sci-libs/gmsh )
gsl? ( sci-libs/gsl )
hdf5? ( sci-libs/hdf5[mpi=] )
@@ -102,6 +103,7 @@ src_configure() {
-DDEAL_II_WITH_ASSIMP="$(usex assimp)"
-DDEAL_II_WITH_ARPACK="$(usex arpack)"
-DDEAL_II_WITH_CUDA="$(usex cuda)"
+ -DDEAL_II_WITH_GINKGO="$(usex ginkgo)"
-DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
-DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
-DDEAL_II_WITH_GMSH="$(usex gmsh)"