summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/stride/stride-20011129-r1.ebuild')
-rw-r--r--sci-biology/stride/stride-20011129-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-biology/stride/stride-20011129-r1.ebuild b/sci-biology/stride/stride-20011129-r1.ebuild
new file mode 100644
index 000000000000..0848427631a0
--- /dev/null
+++ b/sci-biology/stride/stride-20011129-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Protein secondary structure assignment from atomic coordinates"
+HOMEPAGE="http://webclu.bio.wzw.tum.de/stride/"
+SRC_URI="
+ ftp://ftp.ebi.ac.uk/pub/software/unix/${PN}/src/${PN}.tar.gz
+ http://dev.gentoo.org/~jlec/distfiles/${PN}-20060723-update.patch.bz2"
+
+SLOT="0"
+LICENSE="STRIDE"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}"
+
+RESTRICT="mirror bindist"
+
+src_prepare() {
+ # this patch updates the source to the most recent
+ # version which was kindly provided by the author
+ epatch \
+ "${DISTDIR}/${PN}-20060723-update.patch.bz2" \
+ "${FILESDIR}"/${PN}-LDFLAGS.patch
+
+ # fix makefile
+ sed -e "/^CC/s|gcc -g|$(tc-getCC) ${CFLAGS}|" -i Makefile || \
+ die "Failed to fix Makefile"
+}
+
+src_install() {
+ dobin ${PN}
+}