summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ndppd')
-rw-r--r--net-misc/ndppd/Manifest1
-rw-r--r--net-misc/ndppd/files/ndppd.initd14
-rw-r--r--net-misc/ndppd/metadata.xml11
-rw-r--r--net-misc/ndppd/ndppd-0.2.3.ebuild25
4 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/ndppd/Manifest b/net-misc/ndppd/Manifest
new file mode 100644
index 000000000000..f44c7ea3c57a
--- /dev/null
+++ b/net-misc/ndppd/Manifest
@@ -0,0 +1 @@
+DIST ndppd-0.2.3.tar.gz 31459 SHA256 047764681c0b6409f9ac011359f83140639d6f62697df2c9f4f2180985017f9c SHA512 3e9a1b84c2aea81c863d384514b528e1944f592ee057a42553d53804899c880519354f8a5049102a7753b30a99fe69dfbd16ef5686c890345160ffb22f3adca0 WHIRLPOOL dc5332dd84b03701b3050e818694de5f017594b2f7e2a0231b6fac437a7f14d74a1388cdbfca9549c2e4eb10894909d9525fd0dc84b4b52528878fe367c540c2
diff --git a/net-misc/ndppd/files/ndppd.initd b/net-misc/ndppd/files/ndppd.initd
new file mode 100644
index 000000000000..67d6de86f9c0
--- /dev/null
+++ b/net-misc/ndppd/files/ndppd.initd
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command="/usr/sbin/ndppd"
+pidfile="/var/run/ndppd.pid"
+command_args="-p $pidfile -d"
+start_stop_daemon_args="--quiet"
+description="Proxies NDP messages between interfaces."
+
+depend() {
+ use net
+}
diff --git a/net-misc/ndppd/metadata.xml b/net-misc/ndppd/metadata.xml
new file mode 100644
index 000000000000..70b099927c12
--- /dev/null
+++ b/net-misc/ndppd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <longdescription>
+ ndppd, or NDP Proxy Daemon, is a daemon that proxies NDP (Neighbor Discovery Protocol) messages between interfaces.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/ndppd/ndppd-0.2.3.ebuild b/net-misc/ndppd/ndppd-0.2.3.ebuild
new file mode 100644
index 000000000000..a26fdf95061e
--- /dev/null
+++ b/net-misc/ndppd/ndppd-0.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Proxies NDP messages between interfaces"
+HOMEPAGE="http://priv.nu/projects/ndppd/"
+SRC_URI="http://priv.nu/projects/ndppd/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install()
+{
+ emake PREFIX=/usr DESTDIR="${D}" install
+ insinto /etc
+ newins ndppd.conf-dist ndppd.conf
+ newinitd "${FILESDIR}"/ndppd.initd ndppd
+}