summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/lbdb')
-rw-r--r--net-mail/lbdb/Manifest1
-rw-r--r--net-mail/lbdb/lbdb-0.39.ebuild52
-rw-r--r--net-mail/lbdb/metadata.xml9
3 files changed, 62 insertions, 0 deletions
diff --git a/net-mail/lbdb/Manifest b/net-mail/lbdb/Manifest
new file mode 100644
index 000000000000..1740bd61e9e9
--- /dev/null
+++ b/net-mail/lbdb/Manifest
@@ -0,0 +1 @@
+DIST lbdb_0.39.tar.gz 158802 SHA256 4083ce4abde18ac949ca6eab453b3b7227a5aa2c737c9ad8ecbb0152fabfafc6 SHA512 f37fd3261fa132d6320039f43765624d4eff3508e20f581688222ab9add4f3846c772fdc6d6bb936d572634b78bae0a2403c6bcf034ed19e2d54d95a744cba1e WHIRLPOOL 25bcc1b4fc03acbd7fb13b7e2864f010b8f11e7a2809a7b36eef6af1e81d67ce295a438d6cb52e8171a7e7d9321725d69682c278634382d58974be9cba0ba273
diff --git a/net-mail/lbdb/lbdb-0.39.ebuild b/net-mail/lbdb/lbdb-0.39.ebuild
new file mode 100644
index 000000000000..798f25baa34d
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.39.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+LICENSE="GPL-2"
+IUSE="pda ldap finger nis abook crypt evo"
+
+DEPEND="dev-libs/libvformat
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_configure() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if use evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/$(get_version_component_range 1-2 ${evoversion})/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --enable-lbdb-dotlock \
+ --without-pgpk --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb
+}
+
+src_install () {
+ emake install_prefix="${D}" install
+ dodoc README TODO debian/changelog
+}
diff --git a/net-mail/lbdb/metadata.xml b/net-mail/lbdb/metadata.xml
new file mode 100644
index 000000000000..9ab517fb5838
--- /dev/null
+++ b/net-mail/lbdb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <use>
+ <flag name="abook">Enables <pkg>app-misc/abook</pkg> support</flag>
+ <flag name="finger">Enables finger support</flag>
+ </use>
+</pkgmetadata>