summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/dwun/dwun-0.96e-r2.ebuild')
-rw-r--r--net-dialup/dwun/dwun-0.96e-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dialup/dwun/dwun-0.96e-r2.ebuild b/net-dialup/dwun/dwun-0.96e-r2.ebuild
new file mode 100644
index 000000000000..e16a3285f106
--- /dev/null
+++ b/net-dialup/dwun/dwun-0.96e-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="Dialer Without a Useful Name (DWUN)"
+HOMEPAGE="http://dwun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2" # GPL-2 only for init script
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "s:TODO QUICKSTART README UPGRADING ChangeLog COPYING AUTHORS::" "${S}/Makefile.in"
+}
+
+src_configure() {
+ econf --with-docdir=share/doc/${PF} || die "econf failed."
+}
+
+src_install() {
+ einstall || die "install failed."
+
+ insinto /etc
+ newins doc/examples/complete-rcfile dwunrc
+ newins debian/dwunauth dwunauth
+ newinitd "${FILESDIR}/dwun" dwun
+
+ dodoc AUTHORS ChangeLog QUICKSTART README TODO UPGRADING
+}
+
+pkg_postinst() {
+ elog
+ elog 'Make sure you have "net-dialup/ppp" merged if you intend to use dwun'
+ elog "to control a standard PPP network link."
+ elog "See /usr/share/doc/${P}/QUICKSTART for instructions on"
+ elog "configuring dwun."
+ elog
+}