summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/calamaris/calamaris-2.99.4.5.ebuild')
-rw-r--r--net-analyzer/calamaris/calamaris-2.99.4.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild b/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild
new file mode 100644
index 000000000000..446233781cb7
--- /dev/null
+++ b/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="parses logfiles of a wide variety of web proxy servers and generates reports"
+HOMEPAGE="https://cord.de/calamaris-english"
+SRC_URI="https://cord.de/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/GDGraph
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(use lib\).*$:\1 '/usr/share/';:" \
+ calamaris || die
+}
+
+src_install() {
+ dobin calamaris calamaris-cache-convert
+
+ insinto /usr/share/${PN}
+ doins *.pm
+
+ doman calamaris.1
+
+ dodoc BUGS CHANGES EXAMPLES EXAMPLES.v3 README TODO calamaris.conf
+}