summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/tvheadend/tvheadend-9999.ebuild')
-rw-r--r--media-tv/tvheadend/tvheadend-9999.ebuild39
1 files changed, 29 insertions, 10 deletions
diff --git a/media-tv/tvheadend/tvheadend-9999.ebuild b/media-tv/tvheadend/tvheadend-9999.ebuild
index 495a3d139734..731463da2f41 100644
--- a/media-tv/tvheadend/tvheadend-9999.ebuild
+++ b/media-tv/tvheadend/tvheadend-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils git-2 linux-info systemd toolchain-funcs user
+inherit eutils git-r3 linux-info systemd toolchain-funcs user
DESCRIPTION="Tvheadend is a TV streaming server and digital video recorder"
HOMEPAGE="https://tvheadend.org/"
@@ -14,18 +14,26 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="avahi ccache +dvb +dvbscan ffmpeg imagecache inotify uriparser xmltv zlib"
+IUSE="avahi capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zlib"
-DEPEND="dev-libs/openssl:0=
+RDEPEND="dev-libs/openssl:=
+ virtual/libiconv
avahi? ( net-dns/avahi )
- ccache? ( dev-util/ccache )
- dvb? ( virtual/linuxtv-dvb-headers )
- ffmpeg? ( virtual/ffmpeg )
+ dbus? ( sys-apps/dbus )
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:0= )
+ libav? ( media-video/libav:= )
+ )
+ hdhomerun? ( media-libs/libhdhomerun )
uriparser? ( dev-libs/uriparser )
- zlib? ( sys-libs/zlib )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ dvb? ( virtual/linuxtv-dvb-headers )
+ capmt? ( virtual/linuxtv-dvb-headers )
virtual/pkgconfig"
-RDEPEND="${DEPEND}
+RDEPEND+="
dvbscan? ( media-tv/linuxtv-dvb-apps )
xmltv? ( media-tv/xmltv )"
@@ -45,13 +53,24 @@ src_prepare() {
src_configure() {
econf --prefix="${EPREFIX}"/usr \
--datadir="${EPREFIX}"/usr/share \
- $(use_enable avahi) \
- $(use_enable ccache) \
+ --disable-hdhomerun_static \
+ --disable-libffmpeg_static \
+ --disable-ccache \
--disable-dvbscan \
+ $(use_enable avahi) \
+ $(use_enable capmt) \
+ $(use_enable constcw) \
+ $(use_enable cwc) \
+ $(use_enable dbus) \
$(use_enable dvb linuxdvb) \
$(use_enable ffmpeg libav) \
+ $(use_enable hdhomerun hdhomerun_client) \
$(use_enable imagecache) \
$(use_enable inotify) \
+ $(use_enable iptv) \
+ $(use_enable satip satip_server) \
+ $(use_enable satip satip_client) \
+ $(use_enable timeshift) \
$(use_enable uriparser) \
$(use_enable zlib)
}