summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/ax25-tools/ax25-tools-0.0.10_rc5-r1.ebuild14
-rw-r--r--media-radio/ax25-tools/files/ax25-tools-0.0.10-fix-pointer-types.patch35
2 files changed, 45 insertions, 4 deletions
diff --git a/media-radio/ax25-tools/ax25-tools-0.0.10_rc5-r1.ebuild b/media-radio/ax25-tools/ax25-tools-0.0.10_rc5-r1.ebuild
index 17ee50418cad..aee863ad2462 100644
--- a/media-radio/ax25-tools/ax25-tools-0.0.10_rc5-r1.ebuild
+++ b/media-radio/ax25-tools/ax25-tools-0.0.10_rc5-r1.ebuild
@@ -6,9 +6,14 @@ EAPI="8"
MY_P=${P/_/-}
DESCRIPTION="Basic AX.25 (Amateur Radio) administrative tools and daemons"
-HOMEPAGE="http://www.linux-ax25.org/"
-SRC_URI="http://www.linux-ax25.org/pub/${PN}/${MY_P}.tar.gz"
-
+HOMEPAGE="
+ https://linux-ax25.in-berlin.de/
+ https://packet-radio.net/ax-25/
+" # NOTE: ...in-berlin.de does not work but subdomains do
+SRC_URI="
+ https://linux-ax25.in-berlin.de/pub/${PN}/${MY_P}.tar.gz
+ https://ham.packet-radio.net/packet/ax25/ax25-apps/${MY_P}.tar.gz
+"
S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
@@ -30,10 +35,11 @@ RDEPEND="${DEPEND}
sys-libs/zlib"
src_prepare() {
- eapply_user
if use elibc_musl ; then
eapply -p1 "${FILESDIR}/${PN}-0.0.10-musl.patch"
fi
+ eapply -p1 "${FILESDIR}/${PN}-0.0.10-fix-pointer-types.patch"
+ eapply_user
}
src_configure() {
diff --git a/media-radio/ax25-tools/files/ax25-tools-0.0.10-fix-pointer-types.patch b/media-radio/ax25-tools/files/ax25-tools-0.0.10-fix-pointer-types.patch
new file mode 100644
index 000000000000..ca74a4970e08
--- /dev/null
+++ b/media-radio/ax25-tools/files/ax25-tools-0.0.10-fix-pointer-types.patch
@@ -0,0 +1,35 @@
+diff --git a/tcpip/rip98d.c b/tcpip/rip98d.c
+index 50df60e..70b92f1 100644
+--- a/tcpip/rip98d.c
++++ b/tcpip/rip98d.c
+@@ -243,7 +243,7 @@ int main(int argc, char **argv)
+ loc_addr.sin_addr.s_addr = htonl(INADDR_ANY);
+ loc_addr.sin_port = htons(RIP_PORT);
+
+- if (bind(s, &loc_addr, sizeof(loc_addr)) < 0) {
++ if (bind(s, (struct sockaddr *)&loc_addr, sizeof(loc_addr)) < 0) {
+ perror("rip98d: bind");
+ close(s);
+ return 1;
+diff --git a/tcpip/ttylinkd.c b/tcpip/ttylinkd.c
+index c530d73..10f568e 100644
+--- a/tcpip/ttylinkd.c
++++ b/tcpip/ttylinkd.c
+@@ -43,7 +43,7 @@
+
+ #include <syslog.h>
+ #include <sys/types.h>
+-#include <sys/errno.h>
++#include <errno.h>
+ #include <sys/time.h>
+ #include <sys/ioctl.h>
+
+@@ -308,7 +308,7 @@ int main(int argc, char *argv[])
+ exit(1);
+ }
+
+- if (bind(ctl_skt, &ctl_sin, sizeof(ctl_sin)) != 0)
++ if (bind(ctl_skt, (struct sockaddr *)&ctl_sin, sizeof(ctl_sin)) != 0)
+ {
+ syslog(LOG_DAEMON | LOG_CRIT, "main(): Error when trying to bind() control socket.");
+ close(skt);