summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/KochMorse')
-rw-r--r--media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild33
-rw-r--r--media-radio/KochMorse/KochMorse-0.99.6.ebuild26
-rw-r--r--media-radio/KochMorse/Manifest1
-rw-r--r--media-radio/KochMorse/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild b/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild
new file mode 100644
index 000000000000..32062a7750d7
--- /dev/null
+++ b/media-radio/KochMorse/KochMorse-0.99.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Morse-tutor for Linux using the Koch-method"
+HOMEPAGE="http://KochMorse.googlecode.com/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyalsaaudio[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -e 's:Categories=Application;:Categories=:' \
+ -i kochmorse.desktop || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
diff --git a/media-radio/KochMorse/KochMorse-0.99.6.ebuild b/media-radio/KochMorse/KochMorse-0.99.6.ebuild
new file mode 100644
index 000000000000..d7541b76cfa8
--- /dev/null
+++ b/media-radio/KochMorse/KochMorse-0.99.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Morse-tutor for Linux using the Koch-method"
+HOMEPAGE="http://KochMorse.googlecode.com/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/pyalsaaudio
+ dev-python/pygtk"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
diff --git a/media-radio/KochMorse/Manifest b/media-radio/KochMorse/Manifest
new file mode 100644
index 000000000000..cea254e75f17
--- /dev/null
+++ b/media-radio/KochMorse/Manifest
@@ -0,0 +1 @@
+DIST KochMorse-0.99.6.tar.gz 30497 SHA256 c481c4bfa2315c5dee0c20c972e77dd406fe283a85330ec6bae91b73b71fbdf6 SHA512 0803f3fb092962bebffccac143dd4410330d529ec1fe3a8a0c377f640349e0a8f5c254772c5ed7e63cf63c47ce14f304658b4870c78cf89c391823c93ab9b005 WHIRLPOOL 89a5f07d23d9627c9e6c48f938dfc5ee07ec92c5c6504af1a8f210b83c8ee5e0bfac8b876fb52b07d428c2556998f74b5a8d446402da0b35fc16321712917fda
diff --git a/media-radio/KochMorse/metadata.xml b/media-radio/KochMorse/metadata.xml
new file mode 100644
index 000000000000..6999620a1135
--- /dev/null
+++ b/media-radio/KochMorse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">KochMorse</remote-id>
+ </upstream>
+</pkgmetadata>