summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/eog-plugins/eog-plugins-3.16.6.ebuild')
-rw-r--r--media-gfx/eog-plugins/eog-plugins-3.16.6.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-gfx/eog-plugins/eog-plugins-3.16.6.ebuild b/media-gfx/eog-plugins/eog-plugins-3.16.6.ebuild
index 2247c807dd29..0cd2daf86631 100644
--- a/media-gfx/eog-plugins/eog-plugins-3.16.6.ebuild
+++ b/media-gfx/eog-plugins/eog-plugins-3.16.6.ebuild
@@ -5,7 +5,7 @@ EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{3_4,3_5} )
-inherit gnome2 python-r1
+inherit gnome2 python-single-r1
DESCRIPTION="Eye of GNOME plugins"
HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="+exif flickr map picasa +python"
REQUIRED_USE="
map? ( exif )
- python? ( ^^ ( $(python_gen_useflags '*') ) )
+ python? ( ${PYTHON_REQUIRED_USE} )
"
RDEPEND="
@@ -49,7 +49,7 @@ DEPEND="${RDEPEND}
"
pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {