summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mednafen/files/mednafen-0.9.39.2-remove-cflags.patch')
-rw-r--r--games-emulation/mednafen/files/mednafen-0.9.39.2-remove-cflags.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games-emulation/mednafen/files/mednafen-0.9.39.2-remove-cflags.patch b/games-emulation/mednafen/files/mednafen-0.9.39.2-remove-cflags.patch
new file mode 100644
index 000000000000..31c35d7287b4
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.9.39.2-remove-cflags.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -88,21 +88,6 @@
+ AC_CHECK_LIB([z], [zlibVersion],[], AC_MSG_ERROR([*** zlib not found!]))
+ AC_SUBST([ZLIB_LIBS], [-lz])
+
+-dnl -fno-fast-math and -fno-unsafe-math-optimizations to make sure it's disabled, as the fast-math feature on certain older
+-dnl versions of gcc produces horribly broken code(and even when it's working correctly, it can have somewhat unpredictable effects).
+-dnl
+-dnl -fno-aggressive-loop-optimizations because I don't trust gcc's aggressive loop optimizations, and there miiight be old code
+-dnl in Mednafen that would cause problems.
+-dnl
+-dnl -fomit-frame-pointer is required for some x86 inline assembly to compile.
+-dnl
+-OPTIMIZER_FLAGS=""
+-AX_CFLAGS_GCC_OPTION([-fno-fast-math], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fno-unsafe-math-optimizations], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fno-aggressive-loop-optimizations], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fno-ipa-icf], OPTIMIZER_FLAGS)
+-AX_CFLAGS_GCC_OPTION([-fomit-frame-pointer], OPTIMIZER_FLAGS)
+-
+ dnl
+ dnl Aggressively try to disable PIC and PIE, as it has a significant performance overhead and will
+ dnl break some code(with compile-time failures or run-time assert()s triggering).