summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild55
-rw-r--r--dev-util/pycharm-professional/Manifest1
-rw-r--r--dev-util/pycharm-professional/pycharm-professional-2019.3.1.ebuild58
-rw-r--r--dev-util/wstool/Manifest2
-rw-r--r--dev-util/wstool/files/prefix2.patch26
-rw-r--r--dev-util/wstool/wstool-0.1.13.ebuild62
-rw-r--r--dev-util/wstool/wstool-0.1.17.ebuild62
8 files changed, 115 insertions, 152 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 90c08e4afa63..a55a26d26855 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,4 +1,5 @@
DIST pycharm-community-2019.2.3.tar.gz 360509772 BLAKE2B 8924e6b5e2823c26a96531d14bc60f01f0849a5cca3c87bdff7c23c304081e668aecb1b2c681622c472cacf4b2e1f58c5fa4e42624f204491d27e37785146fd3 SHA512 65f834ba20cddb93533d596430f8b537167f32e99d224758d9fd4407f95304609912dec7f11cf61f9edf2e30722f1624250f44765c0f83dcbf6815bb8c35d9d9
DIST pycharm-community-2019.2.4.tar.gz 363680469 BLAKE2B d550dc8144746c0b4bcff408531eba289896dc325eea99a2d2a4363cfaca00de55045cff54a3163acd15105b0705dc48ac28374831bd6f0f6842823cdf4b5ceb SHA512 f7d12ccd8309bf547d1f37853977772d7ab023ebebcc71c6f09f71a21ae9bfceb8718d9ebf77a7717e1b145f56ea902d8d02d573d658b7db540696fb9630b0d3
DIST pycharm-community-2019.2.5.tar.gz 363809835 BLAKE2B 12310ca0c5a497d70f644d7eaf0b2de2ebe3c6bbaa30727df3fb7381e063facf3ee256af0a8636317559dab2573092e482dfa5baccfc9bef20cafd12e9c28734 SHA512 9054c6a9e48e609b45d786b66db045457d33f916248e949a8d6997e53e4a3b5fe0da00757f13c3cb48ab5f074c971e200d42b14f7941a7d91e1c903f3b5e244a
+DIST pycharm-community-2019.3.1.tar.gz 389620376 BLAKE2B a780ab27feef9747539d9cd607b67c7e047d0a7c1eb6b090a63c4f1c11c80c49e5091a29d80ea249ace1f16acdcd418f0a4901e10c2c623e792da9d7d0e7c9d6 SHA512 4bfa78a5f3993e85ad5ba624ed9e586d195b9f4bffa8bd764e8dba27edc1cdc0bd2b3bba86135156c1f306601db290703e61e7561badc7dcb634dc5826134b1f
DIST pycharm-community-2019.3.tar.gz 385414079 BLAKE2B 6a3a4393ba6ef84a7ec09c2f6ea0ce631ea1d4a004686beeedbee91ee2d3de6273455ef1e8e9f8f0f42360f9b4e42741d81a11825fd9c53e2ed90a987661ba20 SHA512 371619a5716de4df1fd68307f87c877eb435b30f797f06305b228566380f658a18f25022deaa581af9653a5745f2cee0157a9ae83b7be9b97f80aea8b4889496
diff --git a/dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild b/dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild
new file mode 100644
index 000000000000..3bd1b2cb4101
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2019.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-libs/libdbusmenu
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/pycharm-professional/Manifest b/dev-util/pycharm-professional/Manifest
index 72b967ec4ff9..76fa715e1c00 100644
--- a/dev-util/pycharm-professional/Manifest
+++ b/dev-util/pycharm-professional/Manifest
@@ -1,4 +1,5 @@
DIST pycharm-professional-2019.2.3.tar.gz 482051405 BLAKE2B e299c2d545b808ed15b4775acb003137467694f528a088cd84d7055a9c15ead96a9e0ac6599374faf60fab3c2ca72a390157130411f4b15bc2b7e3f4b41f0c8e SHA512 4474a74d2762b202100ddbcdfa3807a8136bd392200c79b795cee34a843716218ac21d1d7ed3ac7df9b3c6241f77658a535274759473871cd23a4cc4cfafcfdf
DIST pycharm-professional-2019.2.4.tar.gz 485589877 BLAKE2B c2af015129eec902927ac1b33860ff696e7e3f994a1c827b6e31c84a87a6163262c95a579ec2d4d3c801612af8f8f23b23b432db470f30b199ddca7c6874a37a SHA512 c4fa438ee4ef1de66839a225f61e2b8ecb6e49f41da4099fe0ed8da4840c72c34886a76e090e47fc5ad9f7112b339fec01f5617935e490314d7e73a4585f4ce9
DIST pycharm-professional-2019.2.5.tar.gz 485853232 BLAKE2B 3bb3576dc8919bdab511a1003353fc910ace2a3553fa7fdb116545c3eceebafc28804abacb88af06ca9c399a0a9c75244fd624d0a84e6db91a56c4ca00398fa8 SHA512 f35d49a0df01431aa72af225e09dfdf2b4f535b342ce3ab4725853a02b524a19a9da89dabdd72a08e294fce5387067ee5a7cc005c28c29717771867ca3377848
+DIST pycharm-professional-2019.3.1.tar.gz 509724729 BLAKE2B cd466d9c2b0f9be8442c719066d5647f0b9631dde38b782d23250207760247380419d7470826da2d5c4203dbca2742aa8fcd1987a4204d229cd700ac6f6a68f2 SHA512 3c3ad0546926dac4a0e336e04a16bb5f630066c7b2abeb16eda698fcc92dd0c165237bb3ad9b6382b38b989e67b8c3a4649bf8361421c7da6916a99eb3ea4633
DIST pycharm-professional-2019.3.tar.gz 503439093 BLAKE2B 9d28800534320986cd513fa48cd5f39ea5bb848cd947fdece0289d3c41d5198f3487e453296fcc718057a05d8d0077bc25e209b955dd59ad3bcfa76d1cf94966 SHA512 ec81f418ffd22a8911050a51eeb01c853ded55c528856a4b39b3402cb52ec8b3ab3517a8a4f2b90872437a2740a189d40bc322ee78231cdeb102f1ae60607fa6
diff --git a/dev-util/pycharm-professional/pycharm-professional-2019.3.1.ebuild b/dev-util/pycharm-professional/pycharm-professional-2019.3.1.ebuild
new file mode 100644
index 000000000000..9196130c9fd9
--- /dev/null
+++ b/dev-util/pycharm-professional/pycharm-professional-2019.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-libs/libdbusmenu
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm
+ opt/${PN}/bin/libyjpagent-linux.so
+ opt/${PN}/bin/libyjpagent-linux64.so"
+
+MY_PN=${PN/-professional/}
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/wstool/Manifest b/dev-util/wstool/Manifest
index 235a4850546e..e04952ad72f1 100644
--- a/dev-util/wstool/Manifest
+++ b/dev-util/wstool/Manifest
@@ -1,3 +1 @@
-DIST wstool-0.1.13.tar.gz 75188 BLAKE2B 6a34aa04e4a076a75dacf24faf789d5295f6ad9afbbdddae480d8cdd11db63940faeca2c5936a2432aeccae5274e2e9e4e824f303460fe96f95c0d17abeeb9c1 SHA512 4d54f78ca044d31d927de1c3387536d0447ece77672c555845adf54e47f07adb67e6e9c866bc2719aae468aeeb26c900b3784e0ec7cf014c8118e841a92dca14
-DIST wstool-0.1.17.tar.gz 76168 BLAKE2B 4862df0ff16a5102e42d3ed683dbd9e8eb432aaf44f6e641fba6bb6f5d962645685b0fc9ca11f3c8adbe15dbef33086b93e3f9136073f7f181b5da37522e28fa SHA512 13533354a40723137baadc125425a2ec3d6a441da4870f04a9e17c53509ee4d3dc27df1a59edc2c3985a05fbd66a045539e9814f73509ee527fb763f8a804626
DIST wstool-0.1.18.tar.gz 80595 BLAKE2B ed90fc5c63ab5d775dfb49ddacc6da6e285aeb5078cf471c0d504659a9e322fde27797e4d05fd56dff4b9958558200cf05e46cf7ae71fd1231ab63048e668808 SHA512 fda9c679183c605048ed024a57b07fd2d9b644978a3e4ff89c3716b74d8e4ba0124779bcdf88a75fdbbf47c765b7ab63db7c84a55a6e1744fc6f955649590c48
diff --git a/dev-util/wstool/files/prefix2.patch b/dev-util/wstool/files/prefix2.patch
deleted file mode 100644
index 934443f98707..000000000000
--- a/dev-util/wstool/files/prefix2.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: wstool-0.1.13/setup.py
-===================================================================
---- wstool-0.1.13.orig/setup.py
-+++ wstool-0.1.13/setup.py
-@@ -26,18 +26,11 @@ def _resolve_prefix(prefix, type):
- # issue: https://github.com/vcstools/wstool/issues/81
- osx_system_prefix = '/System/Library/Frameworks/Python.framework/Versions'
- if type == 'man':
-- if prefix == '/usr':
-- return '/usr/share'
-- if sys.prefix.startswith(osx_system_prefix):
-- return '/usr/local/share'
-+ return os.path.join(prefix, 'share')
- elif type == 'bash_comp':
-- if prefix == '/usr':
-- return '/'
-- if sys.prefix.startswith(osx_system_prefix):
-- return '/usr/local'
-+ return os.path.join(prefix, '../')
- elif type == 'zsh_comp':
-- if sys.prefix.startswith(osx_system_prefix):
-- return '/usr/local'
-+ return os.path.join(prefix, '../')
- else:
- raise ValueError('not supported type')
- return prefix
diff --git a/dev-util/wstool/wstool-0.1.13.ebuild b/dev-util/wstool/wstool-0.1.13.ebuild
deleted file mode 100644
index 30a7bd56fa00..000000000000
--- a/dev-util/wstool/wstool-0.1.13.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Commands to manage several local SCM repositories for ROS"
-HOMEPAGE="http://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/sphinx
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/bzr
- dev-vcs/mercurial
- dev-vcs/subversion
- )
-"
-
-PATCHES=( "${FILESDIR}/prefix2.patch" )
-DISTUTILS_IN_SOURCE_BUILD="yes"
-
-python_test() {
- # From travis.yml
- # Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
- # Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
- # Set the bzr user
- bzr whoami "Your Name <name@example.com>"
- # command to run tests
- nosetests --with-coverage --cover-package=wstool || die
-}
diff --git a/dev-util/wstool/wstool-0.1.17.ebuild b/dev-util/wstool/wstool-0.1.17.ebuild
deleted file mode 100644
index 44cd350a809f..000000000000
--- a/dev-util/wstool/wstool-0.1.17.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/wstool"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Commands to manage several local SCM repositories for ROS"
-HOMEPAGE="http://wiki.ros.org/wstool"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/vcstools/wstool/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/sphinx
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/bzr
- dev-vcs/mercurial
- dev-vcs/subversion
- )
-"
-
-PATCHES=( "${FILESDIR}/prefix2.patch" )
-DISTUTILS_IN_SOURCE_BUILD="yes"
-
-python_test() {
- # From travis.yml
- # Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
- # Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
- # Set the bzr user
- bzr whoami "Your Name <name@example.com>"
- # command to run tests
- nosetests --with-coverage --cover-package=wstool || die
-}